Questions & Answers

closed [Completed 3.5] Improve Studio One's Overall CPU Efficiency

+400 votes
2,439 views
asked Dec 16, 2016 in Studio One 3 Feature Requests by Funkybot (15,340 points)
closed May 23 by LMike
This is a general feature request...Studio One's CPU performance can and should continue to be improved upon. Cubase has ASIO Guard, Reaper has Anticipative FX Processing, Sonar is regular emphasizing improved "multicore load balancing," Studio One should similarly look to continuously improve CPU usage.

Note: I'm not measuring CPU usage by the readout of the performance monitor (which shows the load on the most stressed core only), but rather by how many tracks/effects can be run without glitches. Example: a project that glitches on playback in S1 will often play smoothly in Reaper with room to spare.
closed with the note: New dual / low latwncy feature

19 Answers

+23 votes
answered Dec 16, 2016 by -Luis- (13,060 points)

Thank you for the feature request. 

If anyone else agrees or disagrees, then please vote it up, or down. 

To vote:

In agreement click on the little blue triangle pointing up.

In disagreement click on the little blue triangle pointing down.

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. 

Just viewing and agreeing but not clicking on the vote does not help the issue. 

Please click on one or the other. 

+7 votes
answered Dec 18, 2016 by bstin (700 points)
A Hybrid Audio engine would go a long way to alleviate CPU efficiency concerns (automagic buffer size changes for playback vs tracking).
+5 votes
answered Feb 2 by marcz (630 points)
Hi Guy,

For your information. I also had a CPU usage problem in Studio One 3. In some cases with several virtual instruments (eg a project with BFD3 which is very greedy, EZD, Modo Bass, HAlion, Presence and Kontakt) and 37 audio tracks, My system in S1 was at 90% CPU usage. I did not want to change my system because it worked very well with other DAWs. So I tried to understand why my system was quickly saturated. I found a guy who was very strong in hardware and he found that my system using S1 took a lot of CPU resources because of the integrated GPU  to my system. So I made a small investement with a separate GPU and I was surprised to see for the same project to go from 90% to 30% CPU usage.

It may be the same problem you have!
+2 votes
answered Apr 22 by andreafacciolli (190 points)
Indeed 3.3.4 defintely get worse than ever with CPU use. We defintely need a definitive fix on this.
0 votes
answered Dec 18, 2016 by Funkybot (15,340 points)
In response to bstin's post, here's the link to that particular FR, which could be a different way to improve CPU, whereas I see this request as a more generic type request: http://answers.presonus.com/8655/alternative-transform-deactivating-software-monitoring?show=8655#q8655
0 votes
answered Feb 20 by redbird (1,090 points)
edited Feb 20 by redbird
Just a heads up mattcaprio, put a space between the c and the l on click in the last line. It looks like another word with the weird spacing on the forums. Thanks!
0 votes
answered Feb 26 by marcz (630 points)
The problem is even more present in version 3.3.4. I'm on the same PC Studio One, Cubase, Sonar and PT, I have no problem with the 3 DAWs except Studio One. So for the support that tells me that I probably have a problem with my hardware, I would tell them that it does not use S1.

When I open a project from time to time no problem, but often the CPU starts to rave even without reading the project. Even resizing the console for exemple, the CPU goes from 15% to 100%.
Thanks Presonus for correcting this as soon as possible!
Just for that I put last S1 in a comparative test.
0 votes
answered Feb 26 by williamswarner1 (1,190 points)
as marcz points out the cpu usage seems to have risen as of late as now my external plugins are spiking at rates higher than before and i had to actually destroy at least two productions due to studio one actually freezing up on me, a regular vst only pressing one key now yields  a 10% draw on my cpu that used to only illicit about a 1-2% draw before and some vsti's that I have just simply make the cpu just instantly seize up this wasnt ever an issue for me before the last update, also my keystation 88 didnt get recognized 6 times in a row and it took me a long time just to get it programmed right so my carriage controls and all worked,please fix
0 votes
answered Feb 28 by MarkyGoldstein (5,520 points)
The big questions are:

- can we leverage the network?

- what needs to be realtime?

- is invisible background freezing doable?

- is it cheaper to buy 4 quad core computers than to buy one with 16 cores - and can they be linked?

- what about having multiple audio engines running in parallel?

Guys, until we get this: set the buffers high enough.
0 votes
answered Mar 21 by TheNavigator (320 points)
Can we have something similar to Steinbergs "ASIO guard"?

This should solve many of the CPU related issues.

And "automatic rendering when not monitoring" would help a lot as well... I actually wonder why no DAW has something like that.
0 votes
answered Apr 3 by lukemccready (1,430 points)
I switched to Studio One 3.3 from Pro Tools 11. I had never frozen a track previously, almost never maxed my CPU with Pro Tools 11. Now that I'm in Studio One, freezing tracks is completely mandatory. Except that it's not enough. I have a session now with every track frozen and the CPU usage bounces from 85% to maxing with artifacts simply because I am using buses to use effects on groups of channels. It's pretty ridiculous, and of course I can't freeze bus tracks.

Simply adding the Ozone limiter to my master fader made my track export at "1.3x slower than real-time". I didn't even know DAWs could do that.

In Studio One, if I'm only sending one track to a bus for effects, I'm already in the habit of just duplicating that track with 100% wet effects instead, so it can also be frozen. Which is a bit silly, but it works. Yet I'm out of luck with buses that are needed for multiple tracks.

Lately, CPU usage has gotten even weirder. Instruments that normally take 3-5% usage occasionally start bouncing from 25-60% usage, and the list of highest CPU usage plugins changes constantly. Usually just saving my session clears this up and I can return to work, but sometimes I have to close and re-open Studio One.

I feel like I could recommend Studio One as the best DAW, hands down, to anyone other than live performers if CPU usage seemed on par with other DAWs. But I'm the odd one with a heavily overclocked Intel quad core in my desktop. Most producers I meet work on laptops with 2-4 slow cores. It's really hard to recommend Studio One to them based on CPU usage.
0 votes
answered Apr 3 by robsonbatista (340 points)

I am with the same problem that you cpu overloaded with just kontakt and 5 plugins use a macbook pro i5 8gb of ram already when I use the logic the same instrument the same plugin runs normally please fix it soon in Studio one 3

0 votes
answered Apr 5 by violetpow (460 points)
I agree with anybody, that S1 3.4 does not use the CPU efficient. In my case its more the balance between the CPU cores.

I'm working with a 6 core Mac Pro 2013 and for example a "only Audio Tracks" song with several plugins in different tracks uses first 1 core and if the core is maxed out, then it uses the other. But why not like in Logic or Live where the cores are spread around the tracks. In Live i know that it uses first one core per track (i.e. 4 channels for 4 cores) and afterwards more tracks will be spread the tracks to the cores on top. I wonder why S1 is so behind with its "modern codebase"
0 votes
answered Apr 11 by matthewcasey (260 points)
Im on a VERY capable iMac and I am getting CPU spikes when I have one audio track and several (not-that-intensive) instrument tracks.  This needs to be addressed, not as a feature but as a basic guarantee of stability.
0 votes
answered Apr 20 by dmitrypetrenko (1,830 points)
I join! Indeed, it is necessary to optimize the consumption of resources by the program. Compared with my existing Cubase 9, Reaper, Sonar Platinum, Studio One 3 shows the worst results on CPU loading. And this is the only limitation to date, which does not allow leaving S1 the only DAW for me.
0 votes
answered Apr 22 by dennisrenirie (460 points)
same problem over here.

Studio one is pretty cpu intensive compared to other daws with the same plugins, so you have to increase latency to unacceptable/unworkable values
0 votes
answered Apr 22 by dennisrenirie (460 points)
Same problem here, where logic and ableton live dont with the same plugins.

I posted a feature request to lower the latency and cpu load: https://answers.presonus.com/16280/lower-load-and-latency-background-rendering-aka-auto-freeze
0 votes
answered May 7 by scmrecordings (1,260 points)

First, let me say that I completely agree that the CPU efficiency in Studio One is definitely behind that of other DAWs.  Coming from Sonar and Pro Tools, I would say Sonar, at least, is 2-4 times more efficient than Studio One with large projects.  Sonar just did a huge overhaul of it's CPU efficiency and specifically it's multi core efficiency and it's just incredibly powerful now.  I see no reason why Studio One shouldn't be able to do the same.  Also, I believe Sonar has a feature that temporarily bypasses plugins automatically during playback for tracks that have no content or something like that.  Really smart way to save CPU.  So yes, PLEASE update the engine to be more CPU efficient!

All of that said, I love Studio One so much I just can't get away from it. cheeky

But I'm writing here for another reason that hopefully helps people until CPU efficiency is fixed.

I came to this thread and (the other similar feature request) when I searched CPU spikes in Studio One on Google.  I was having horrible CPU spikes that would only show up with larger projects and it was driving me insane.  I'm running an I7 6800k with 64gb of Ram, multiple SSDs, etc. and should not be having random CPU spikes.  I tried running Latency Mon, disabling all my drivers, reinstalling Studio One, killing all my processes, Disabling C states and EIST in BIOS - everything I could find.  Still, the spikes were killing my workflow and making it really hard to get stuff done.

I had read in a few places about disabling Turbo Boost in BIOS (and Turbo Boost Max) but had decided that there was no way I was going to sacrifice CPU power.  Well, it got bad enough that I decided to try it and VOILA - for the first time ever for me in Studio One -

NO CPU SPIKES!

My CPU is about 10-15% higher without Turbo Boost on but finally I have rock solid consistent numbers.  If it's hovering at 35%, it will go up and down maybe 3% but that's it.  Before it would spike to 100 every second or so.  This should be considered a bug in it's own right because no user should have to go into BIOS and disable a CPU feature hat makes it run a lot faster but at least I have a fix that allows me to get work done.

Anyway, I know this was a super long post but this helped me so much and I figured it could help some of you out there as well - at least until the CPU issues with Studio One get ironed out.  Have fun!

0 votes
answered May 8 by ababerkrom (170 points)
I so agree with this. It is sad to see that still nothing seems to have been done. I had studio one v3 for a while, trouble shooting like an idiot, got help that was not really helping (as they tend to give advice only once a day so it takes for ever to try to solve things and all advices you get are things you probably, if you know how to google and/or search the forum, allready tried). There seems no effort in accepting or even researching that it is a S1-3 issue, but just put the ball back at the customer) I am glad to had my purchase refunded, that was the only positive part of the story. Today I thought I check to see what has been done, reading the last few negatives, I guess I will stick with the much friendlier S1-2 for some longer. I wished presonus would do more to make the customer happy...
...