Questions & Answers

Can I use my studiolive 24.4.2 classic with Mac OS Yosemite and PT12?

0 votes
94 views
asked May 14, 2017 in Studio One 1 by lemuelconnell (150 points)
I was running PT10 with Snow Lepord and my classic 24.4.2. I did the update to Yosemite (not even thinking) and universal control wouldn't work. I did what I found on Presonus's website to reinstall, but it hasn't worked. Maybe I did something wrong.

But I was wanting to keep the Yosemite, and upgrade to PT12, but only if I can still use my board. Can anyone let me know if this is a possibility? Thanks!

1 Answer

0 votes
answered May 15, 2017 by butchrichard (94,580 points)
 
Best answer
Use this article to fully remove any previously installed version of Universal Control.

http://support.presonus.com/entries/113168-firestudio-how-do-i-uninstall-reinstall-my-firestudio-drivers-on-a-mac-computer

You may also need this article for OSX 10.10.5 Yosemite

http://presonus.zendesk.com/entries/62974744-OSX-10-10-Yosemite-driver-signing-security-workaround-StudioLive-classic

Install UC 1.7.4

https://pae-web.presonusmusic.com/downloads/products/dmg/PreSonus_Universal_Control-174.dmg

If you continue to have trouble, create a Support Ticket with PreSonus Support.  They can assist you further.
...