Questions & Answers

New MacBook Pro 3.1GHz quad-core Turbo Boost up to 4.1GHz ,USB-C to USB and the Audiobox USB not working.

0 votes
245 views
asked Jul 18, 2017 in AudioBox USB by stanleygonzales (240 points)

I am trying to use my AudioBox USB with my brand new MacBook Pro 3.1GHz quad-core 7th-generation Intel Core i7 processor, Turbo Boost up to 4.1GHz. I am trying to connect my AudioBox USB to the Apple Dongle that adapts to USB-C.  I use Logic X and when I plug the unit into the dongle, it shows up for a minute and then removes the device.  Now it still recognizes the midi function but all the audio is greyed out.  I also noticed it does this is also doing this with the global audio in the computer.  I have contacted Apple about this and they are sending out a couple of different USB-C adapters for me to try because they do not understand why this is happening.  PreSonus, your thoughts?  

3 Answers

0 votes
answered Jul 18, 2017 by stanleygonzales (240 points)
selected Jul 18, 2017 by connorguiberteau
 
Best answer
Thank you for your response but I read this article and it doesn't pertain to my question because this is about the MacBook, not the MacBook Pro.  Also, there is nothing that gives me a definitive answer as to does this product work with USB to USB-C?
commented Jul 18, 2017 by connorguiberteau (15,760 points)

Your answer can be found in the knowledge base.

http://support.presonus.com/hc/en-us/articles/115000057246-MacBook-Pro-Late-2016-Compatibility-Qualification

"We have determined that putting a powered or un-powered USB hub between the AudioBox and the computer resolves the connectivity issue."

0 votes
0 votes
answered Jul 18, 2017 by stanleygonzales (240 points)
THAT WORKED!!!!!!  The hub worked.

Thank you very much!
...