Questions & Answers

My CPU usage is jumping everywhere for no reason?

0 votes
150 views
asked Aug 26, 2017 in Studio One 3 by samashley (350 points)

I have happily used Studio One 3 for nearly a year now and I love it. I use Windows 10 and when I logged on today the CPU usage on studio one is jumping around everywhere from 10% to 50%. I have never had this problem before, it would always stay around the 10% mark.

This is extremely annoying and seems to stop midi playing when switching tracks with low latency instrument monitoring on. Is there any way to fix this apart from wait for a new update? My CPU is easily good enough to run everything and this is running projects I have done before with no problem. 

I can't believe these problems are still going on, I seem to hear about CPU problems with this software every other day but this is the first time I have encountered them myself. VERY frustrating for such an expensive bit of software.

1 Answer

0 votes
answered Aug 29, 2017 by brianmeisner1 (135,640 points)
 
Best answer

Hi Sam,

We have seen a number of high CPU usage issues on our end, but usually are able to find out where the problem is coming from.  Since CPU usage is such a broad topic, affecting all aspects of your computer, the answer is almost always something different in each scenario.  Here are a couple of things to check.

1.  Make sure that you have installed all of your Windows updates.

2.  Open S1 and go to Studio One>Options>Audio Setup and click the "Processing" tab.  Turn the Dropout Protection to "Maximum," especially if you are working with the new low-latency functionality.  Make sure that you have the latest driver installed for your audio interface as well as the latest firmware.  If you are working with a Focusrite device, you will want to contact Focusrite for assistance.  We have seen some high CPU issues with Focusrite interfaces, but have heard good reports from customers after they have contacted Focusrite.  

3.  Increase your Device Block size, aka ASIO buffer size in the control panel for your audio interface, prior to opening Studio One.  

4.  Open the Performance Monitor in Studio One, choose the check box to "Show devices," and see if you can identify a particular plug-in that might be causing the issue.  

For general troubleshooting, you can try re-installing Studio One and removing the settings files from the program.  Here are instructions for removing settings files. 

  1. Go to Help>Open Settings folder.

  2. Copy the contents of the folder over to a folder on your desktop.

  3. Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

  4. Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

  5. Test to see if the problem is resolved. If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.

If you continue to have the issue, please submit a support ticket from within your my.presonus.com account.  Just click on "Support."  Be sure to attach the .nfo file to your ticket when requested to do so and a PreSonus TS Agent would be happy to assist.

...