Questions & Answers

My interface keeps disconnecting from my Toshiba laptop; can you send me the patch that fixes it?

0 votes
193 views
asked Sep 1, 2017 in AudioBox USB by namanrawal (150 points)
- Toshiba Satellite L55-A

- Windows 10 Home v 1703

- FL Studio 12.4 [build 29] - 32Bit

- AudioBox iTwo - Universal Control 2.2.0.44119 Win x86

- N/A

The interface/pre-amp keeps disconnecting from my laptop. I had this issue in the past with a previous build. I opened a ticket for it and I was sent a patch which worked...until the most recent build came out. I was wondering if there was another patch for this firmware version?

Thank you,

Naman

1 Answer

0 votes
answered Sep 15, 2017 by butchrichard (111,660 points)
 
Best answer

> Disconnect the AudioBox from your computer.

> Hit the Windows Key

> Now type “View advanced system settings” and press return

> Click Environment Variables button.

> Click the New button for the top section on this window.

> For "Variable Name:" type this exactly.

devmgr_show_nonpresent_devices

> For "Variable Value:" enter a single number " 1 ".

> Click OK and couple times and then open the Device Manger.

> Click the View menu and check "Show Hidden Devices".

> Right click and Uninstall any "AudioBox", "PreSonus", "USB Audio Device" and or "Unknown Device" you see listed under any category.

> Restart your computer.

> Install the current device drivers.

If you still have trouble, test with a new and or different USB cable.

Test your AudioBox on another computer to determine if it has the same problem.  If so, then your AudioBox may be faulty.

Contact PreSonus Support for further assistance.

...