Questions & Answers

Auto-select a take when recording is finished

+2 votes
43 views
asked Sep 26 in Studio One 3 Feature Requests by ferdinanddemarezoyens (320 points)
From working with Cubase I have a habit of hitting the delete-key after a take I don't like. In S1 nothing happens in that scenario because the take is not selected. I know using Undo will have a similar effect, but automatically selecting a take when a recording is finished (like in Cubase) would still be very welcome.

6 Answers

0 votes
answered Sep 27 by lukemccready (1,430 points)
You're in the habit of hitting Delete, I'm in the habit of hitting Ctrl+Z. You could change or add a hotkey if you want. But it might be worth it just to learn to use the keyboard shortcut to undo after a bad take.

I used the Pro Tools keyboard shortcuts for zooming for years. It was uncomfortable at first trying to zoom in Studio One without copying Pro Tools keyboard shortcuts, but I stuck with it and a couple of weeks later the Studio One method became automatic for me.
0 votes
answered Sep 28 by ferdinanddemarezoyens (320 points)
@lukemccready Yes, that is fair point. When switching to a new DAW, you'd better switch properly and learn the new short cuts. That is what I'm doing. In this case I'm not asking for a short cut to be adapted or added, but a minor work flow enhancement. It would make sense for a take to be selected once you hit stop recording, because other than deleting it, you could also want to normalise it or fire a macro etc. It saves a click. Not a huge gain, but one that has no disadvantages as far as I can see.
0 votes
answered Oct 2 by elijahlucian (1,010 points)
i don't know why it doesn't work for you, but when i stop my playback, the clip that I just recorded is selected and the "delete" key works for me.

I recommend you set up macros to make it work best for you. that's the power of S1 in a nutshell.
0 votes
answered Oct 3 by donaldbaarns (6,390 points)
I'm with the others here. When I stop a recording (spacebar), the last event is selected.

I tried it a few ways (stopping with Spacebar, stopping with mouse click) and in all cases I tried it always highlighted the last recorded event. I could always press the Delete key and remove the most recent recorded event.

You must be doing something different.
0 votes
answered Oct 7 by ferdinanddemarezoyens (320 points)
Odd to see that this works for other people. I've tried again and it still doesn't work. Just to make sure: I'm talking about recording audio and not midi, and I'm recording to layers. Let's say I have 3 layers (takes) already and then I record another one. This take in layer 4 is not selected when I hit the space bar to stop recording. But it is for everyone else who contributed in this thread? Maybe it's because you are all on Mac and I'm on PC? I use out of the box S1 pro, latest version, on W10 64 bit , with an Apollo Twin USB interface.
0 votes
answered Oct 8 by donaldbaarns (6,390 points)
Ah, that's the difference. (I have both PC and Mac, I tested it on my PC with S1 v3.5.2 and Win10 Pro)

You're recording to layers...

That changes the behavior. I haven't tested it that way, and I suspect "Ctrl+Z" is the best option even though it will be slight change from your previous experience/habits. That's assuming you want to Delete. If you want to do other things, then you'll have to click on it.

I'd have to think about why it works the way it does. Usually the developers are pretty smart and consistent about WHY they select what they do, although occasionally they do miss something or make a design decision I would re-think.
...