Questions & Answers

After Studio One 3.5.2 update, Universal Control doesn't pick up AudioBox USB anymore

0 votes
144 views
asked Sep 28 in Studio One 3 by leonardonasir (270 points)

My system info: Microsoft Surface Pro 3 - 128GB, 64-bit OS, x64-based processor

Yesterday I updated to Studio One 3.5.2.44603 Artist. I now have to reinstall the driver for my AudioBox USB. I install the latest driver, which I see is AudioBox USB v1.3 (for PC), and I get this, which looks like an older version to me:

I also have the latest version of Universal Control installed (version 2.3.0.44619). When I open up Universal Control, there are no devices there, looks like this:

Before the update, I was able to see my AudioBox USB in the latest version of Universal Control.

Thanks in advance

1 Answer

+1 vote
answered Sep 28 by brianmeisner1 (128,410 points)
selected Sep 28 by leonardonasir
 
Best answer
Here are some steps to troubleshoot the issue.

1.  Please uninstall Universal Control and install the latest version once more from the following link:

https://www.presonus.com/support/downloads/AudioBox-USB

2.  If the problem persists, you will want to disconnect your Audiobox from it's current USB port and try using a different port.  Preferably one that is on the back of your computer.  Reboot if the port is not picking up the device.  Be sure to also install the firmware update if prompted.

3.  Install all of your Windows updates and give your system a reboot.

If you still continue to have an issue, you will want to log a support ticket from within your my.presonus.com account.  Just click the "Support" tab.
...