Questions & Answers

Make 16.4.2 (Non AI) show up on High Sierra with Firewire to thunderbolt Adapter.

+1 vote
149 views
asked Oct 7 in Classic Mixers by stephennichols1 (210 points)
I made the mistake of updating to High Sierra without first checking compatibility. I have uninstalled and then reinstalled 1.7.4.5 multiple times but my mixer interface still is not recognized. I have the old 16.4.2 pre AI. Am I doing something wrong or do I just need to wait for another dirver update? I am running a firewire to thunderbolt adapter and everything was working perfectly pre update. Also I use logic but also have studio one. Either way nothing is working. Yes I have restarted probably 100 times and reset PRAM. I am on a late 2013 i7 imac and recently reformatted everything because I needed a refresh.

4 Answers

0 votes
answered Oct 11 by stephennichols1 (210 points)
 
Best answer
I was able to fix my issue so I figure I would update anyone with the same issue. First I manually deleted all of the files associated with presonus. Google search manually delete presonus studio live drivers Mac then follow those instructions to the letter including deleting the hidden files. Then shutdown and start back up while resetting pram (in same instructions). Then install the correct driver again from a fresh download. Restart immediately and this all worked perfect for me. Hope this helps!!!
+1 vote
answered Oct 10 by michaeldach (160 points)
It's the same here with my 24.4.2...
0 votes
answered Nov 4 by daviderossi (150 points)
I have the same problem after a high Sierra clean install
0 votes
answered Nov 17 by Deech (720 points)
Same issue with my RM16. S1 and Capture wont' read it. And put in a ticket to Presonus days ago and haven't heard anything.
...