Questions & Answers

Making Studio One 3 Professional recognize EZ Drummer 2 / Superior Drummer

+1 vote
65 views
asked Dec 2 in Studio One 3 by garytarplee1 (300 points)
Hello all,

I searched for the answer to this but everything I have looked at doesnt address my issue. I have Studio One 3 Professional. I have Superior Drummer 3, EZ Mix and Helix Naive. Upon start up, my helix native shows up under "line 6". Toontrack shows up in my VST plug ins, but the folders are empty and I cannot access any of my EZ Mix or Superior Drummer files or audio sounds. I am sure that I must be doing wrong but I cannot figure it out. I have gone to "options", "locations" "VSTplug ins" and ToonTrack does not show up under an accessible folder.

I dont know what else to do! I have been fighting with this for hours now.

Second questions

When I want to add my drums, do I do it under "instrument track"?

5 Answers

0 votes
answered Dec 2 by joeypinter-bilek (190 points)
hey, this, unfortunately, is not an answer. however, i have the same problem (sort of) studio one 3.5 sees SD3 but i haven't a clue how to get it to work like i did in sonar platinum. i haven't even tried to see if EZmix is working. i'm just trying to get something going. if you get any ideas form anyone could you please send them my way.

thanks

jp
0 votes
answered Dec 2 by robertedwards6 (140 points)
I admit I do not own PreSonus to try this on (investigating it today), but I can tell you I've run into this problem on several other DAW's because I was trying to get it to go on a mono track. Absolutely MUST be on a stereo track. Spent 6 hours trying to figure that out on Reaper one day...

Hope that helps.
0 votes
answered Dec 3 by karstenvogt (1,730 points)
Please check:
- did you install Studio One Prof. 64bit? If so did you install your plugins as 64bit version?
- Did you set the path to the 64bit plugins correctly in your Studio One preferences?
- Try resetting the VST-Plugin blacklist (see preferences)

If they show up in your instrument browser, just drag and drop the plugin into the arranger window. A new track will be created automatically.
0 votes
answered Dec 4 by garytarplee1 (300 points)
Its still not recognizing it. I have made sure all plug ins are 64 bit. I have added the plug in, saved, closed the program and I get a ToonTrack (EZ Mix, Superior Drummer 3) folder on the left side of the screen under Files, but the folders are empty. I have uninstalled every program (ToonTrack, Presonus, Sonar Platinum, Helix Native) reinstalled every program and nothing. For giggles, I uninstalled PreSonus and reinstalled Platinum and ToonTrack and Helix Native show up.

Everything is working as a stand alone. I can open EZ Mix and fully operate on its own. Same with Superior Drummer and Helix Native. I have watched numerous videos and everything I have tried, I get the same result. A toontrack file with an empty folder.

SOOOOOO FRUSTRATING!!!

Sweetwater tried to remotely fix and they cannot do it either. They say they have never seen this before.

So, this is where I am at with this situation as of 12/4/2017.
0 votes
answered Dec 6 by garytarplee1 (300 points)
This problem has been solved. Apparently PreSonus wasn't seeing the "common files" folder in the C drive of my computer. Once we realized  that was the issue, we pulled them into PreSonus and everything shows up now.

Problem solved and my PreSonus Studio One 3 Professional is now completely up and running.
...