Questions & Answers

iPads will no longer connect to studio computer via UC Surface

+6 votes
159 views
asked Dec 20, 2017 in Studio 192 USB 3.0 Interfaces by marcmiller (300 points)
I have a single studio computer that is connected to a Studio 192 on it.  I have an iPad (OSX version 9.3.5) that is running the latest version of UC Surface (2.5.0.45267) that used to connect just fine to the studio computer, but has recently stopped connecting.  When I start the app on the iPad, it shows the studio computer (and the correct IP address) as a possible connection, but when I tap it, nothing happens.  I tried installing UC Surface same version to a new iPad (running OSX 11.2.1) and the exact same thing happens.

I have verified that Universal Control is allowed thru my firewall, as well as verifid that the PresonuseHardwareAccessService.exe is also allowed thru the firewall, and I have also verified that UDP port 47809 is allowed thru the firewall.  The studio computer's UC Surface software connects fine and I can control the mixer and all functions from the local computer, but not from remotes and this used to work.  I have followed what (very) scant troubleshooting information is available on this and a few other boards, but nothing works.  It's not a deal-breaker, but I really do like have the UC Surface running on the iPad for quick changes to settings as well as being able to control the talkback mike.

There have been no updates to software here, either the OS or anything else.  I can verify that.

Anyone got any ideas here?  I'm truly stumped- I'm very well versed in networking, and really don't want to go thru a "please dump your settings/reboot your computer" kind of troubleshooting, because I've already done all of that about 35,312 times already.  HELP!!!

9 Answers

+2 votes
answered Dec 21, 2017 by saracarter1 (340 points)

I'm having exactly the same problem with that version of UC Surface on my iPad when it all used to work fine. I've just updated to the latest firmware on the Studio 192 which hasn't helped. I'm on a mac pro running Sierra and my firewall is off. I've deleted and reinstalled UC Surface on the iPad and got the latest iOS.

+2 votes
answered Dec 21, 2017 by albertoleal (530 points)
I´m having the same problem. It is really disappointing - I had a really big session this week and it didnt work at all. The iPad display the my Studio 192 but I tap on it and nothing happens. - Honestly, the connection between UC surface on iPad and my computer was never stable or reliable, but now it doesnt connect at all.

Running UC Surface on iPAd with iOS11 and UC on W10
+2 votes
answered Dec 22, 2017 by davidsimms2 (220 points)
Yep, the latest update to the UC Surface on my computer killed my iPad and Android controls. It's not an option. You should be able to click the settings wheel on your computer to config the iPad or Android device, but that's no longer an option for the 192. Kind really irks me that the main reason I bought the 192 is for this feature. Presonus devs need to just add this few lines of code back into the software.
+1 vote
answered Dec 24, 2017 by jasonringer (200 points)
Same here.

Come on Presonus, this is getting ridiculous.

3 of the last 6 updates have caused me to have to jump through hoops to get UC surface working. And this time, those hoops don't work. I think your app is broken.
+1 vote
answered Dec 30, 2017 by pbaudinat (210 points)
Any idea of the way to install an older (and working)  version of UC SURFACE on an ipad 2 ?
0 votes
answered Jan 5 by mksyzhap (150 points)

me too!!!

I'm android 

When I click on it, nothing happens

0 votes
answered Jan 12 by davidsimms2 (220 points)
Same issue here. I tried rolling back the software, but you need to roll back the firmware on your device (Studio 192 for me) and remove all traces of the driver and UC from your computer's registry. It's a huge pain and not worth the trouble. The easy fix is just adding the code back into the next update to UC.
0 votes
answered Jan 14 by jjguitarist (140 points)
I am having the same exact issue! I made sure that everything is up to date, re installed uc surface, and rebooted ipad. Still nothing. My 192 shows up but when clicked it does nothing. To rule out any problems with pc settings or home network settings I tried the Studio One RC and it works flawlessly. I also downloaded the Qmix-UC and it controls my 192 fine. So the problem must be with the Ipad uc surface ap or UC software on the pc. Hope they remedy this soon!!
0 votes
answered Jan 15 by kevincollins1 (460 points)
I had to downgrade UC. I opened a ticket and that was the advice. Said should be fixed ni next update.
...