Questions & Answers

Please Help. Compatibility of Studio One 3 & Sierra versions

0 votes
96 views
asked Jan 8 in Studio One 3 by timalexander (170 points)

I have: 

  • Mac OS Sierra 10.12.6  
  • Studio One 3.5.0.43196 x64

I have not been making music as such since I got Studio One and, when I set things up, I had some problems with SO3 crashing and it not allowing me to open plugins of any kind.

I now want to start using my Studio One and start making music finally.

I am unclear as to what versions of Studio One work with what OS version and really do not want to make another mistake that will affect my music making.

So, at the risk of asking a silly question:

  • Am I able to update to the latest OS Sierra?
  • Am I able to update to the latest Studio One?
  • Are they compatible?

1 Answer

0 votes
answered Jan 11 by PreSonuSupt4 (161,430 points)
 
Best answer

https://www.presonus.com/products/studio-one/tech-specs

Mac®

  • Mac OS X 10.8.5 or higher
  • Intel® Core 2 Duo processor
    (Intel Core i3 or better recommended)

If you are having issues with application stability, please create a support ticket so that a support agent can assist you in resolving the issue.

...