Questions & Answers

Changing "Windows Audio" sample rate and bit depth

0 votes
76 views
asked Mar 24 in Studio One 3 by reecejones (160 points)
How can I change the sample rate and bit depth of the "Windows Audio" audio device? My sound card supports up to 192kHz sampling at 24 bit, and I have it set as such in Windows settings. Yet Studio One always shows 44.1kHz 16 bit, and then fails to initialise the audio device because the settings do not match.

OS: Windows 10 64 bit, version 1709
Studio One 3 version: 3.5.5.45892, x64
Sound card: Asus Xonar AE
 

(Note: I'm not selecting my sound card directly through Studio One, because for some unknown reason it does not show any inputs, so I can't record anything. I'm also not using ASIO4ALL because that requires the sound card to be configured exclusively, which messes up the sound on everything else on my PC.)

1 Answer

0 votes
answered Mar 24 by reecejones (160 points)
edited Mar 24 by reecejones

Turns out Studio One doesn't handle different output and input sampling rates for the same audio device. I thought my sound card was 192kHz input and output, but in reality only the output was; the input was 96kHz max.
So what mostly fixed the problem was setting the output to the same as the input - 96kHz 24 bit - in Windows' sound settings. Studio One now successfully initialises the audio device.
However it still shows the device as 16 bit, even though it's definitely configured as 24 bit in Windows. I'm wondering if there's any way to change it to the correct bit depth?

...