Questions & Answers

closed Studio One does not scan some of the plugins and I have already checked it many times.

0 votes
897 views
asked May 27, 2016 in Studio One 3 by joonhoahn (290 points)
closed May 2, 2017 by joonhoahn
So one of the things that I noticed with Studio One 3 x64 is that there are a handful of plugins that it does not recognize, most notably the TSE808 x64, which I ended up having to use the 32-bit version of instead via JBridge.

The tech support representative from TSE told me to try using the plugin on Reaper, which I did, and it seemed to work flawlessly, given the fact that JBridge plugins had the word JBridge written in front of the plugin name on Reaper. Reaper was also 64-bit.

I already tried resetting the blacklist. I even went as far as reinstalling the program. The directory C:\Program Files\VstPlugins is still there on the list, and the 64-bit version of TSE808 is still in the same directory. Again, my version of Studio One 3 is also 64-bit.

I tried running depends22 on TSE808, where I found a big chunk of dependencies to be missing, but I looked everywhere for solutions to resolve all of them at once, to no avail. So I know what the problem is, but I could not find a solution other than take the time to look for each dependency and find out where it was meant to be. Does defragmenting help?

ASUS ROG G750JW

Windows 10 64-bit

Studio One 3.2.2 Professional

M-AUDIO Fast Track MKII (Package 6.1.12, Firmware: 0.3.0)

no hardware mixers
closed with the note: My computer had been actively smashed by a relative and I ended up with new drives and an unusable backup. That was the only solution to the problem.

2 Answers

0 votes
answered May 2, 2017 by joonhoahn (290 points)
edited May 2, 2017 by joonhoahn

"1.  Please open Studio One and go to Studio One>Options>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup.  You want to add the directory that you have your plug-ins installed to.  If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or Producer or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One.  Press the "Reset Blacklist" button while you are in this window."

If you have not noticed I have mentioned that I already tried resetting the blacklist. In addition, I am running Studio One Professional, which I have already mentioned as well.

"2.  Right-click Studio One and choose "Run as administrator" when opening the program to determine if there is a possible permissions problem."

"Run as Administrator" is the very first thing that I have tried.

"3.  Studio One will only load 64-bit plug-ins into the 64-bit version of Studio One.  The 32-bit version of Studio One will only load 32-bit plug-ins.  If you loaded your VSTs from the c:\Program Files (x86) folder into Studio One under the "Locations" tab, this is more than likely your 32-bit plug-ins. If you need to install a different bit-version of Studio One, you can do so by downloading the desired version from your my.presonus.com account under My Products>Software>Studio One."

I do believe I already have mentioned that I had both the 32-bit and 64-bit of the plugin in question, so that should be irrelevant.

"4.  Please click the icon of the wrench in the browser window, at the top, right-hand corner of the window, to open the plug-in manager.  Make sure that there is a white dot next to the plug-in, if it shows up in the list.  

5.  If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds."

I already have contacted the creator of the plugin and not even he could provide any solution at all.

As for #4 I am unable to try the solution because my computer was actively smashed by a relative, resulting in both of my drives completely busted, meaning all of my files had been wiped. I did back up all of my files but I could not access them either, which means that I ended up having to reinstall all of the programmes that I had been using. With a technically-new computer I managed to get the 64-bit version of the plugin working just fine.

As of this post, there is no possible solution available, other than backing up all of the files and resetting/reinstalling the OS entirely.

And since I am now getting a new computer this year, I cannot wait to see what I am going to be able to get.

–1 vote
answered Apr 24, 2017 by brianmeisner1 (135,640 points)
One thing you will want to check is the VST manager in Studio One 3.  Go into the Browser window and click the icon of the wrench.  See if the plug-in/s appear.  If they do, just click the dot to the left of the plug-in to make it white.  Below are some general troubleshooting steps to try.

1.  Please open Studio One and go to Studio One>Options>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup.  You want to add the directory that you have your plug-ins installed to.  If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or Producer or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One.  Press the "Reset Blacklist" button while you are in this window.

2.  Right-click Studio One and choose "Run as administrator" when opening the program to determine if there is a possible permissions problem.

3.  Studio One will only load 64-bit plug-ins into the 64-bit version of Studio One.  The 32-bit version of Studio One will only load 32-bit plug-ins.  If you loaded your VSTs from the c:\Program Files (x86) folder into Studio One under the "Locations" tab, this is more than likely your 32-bit plug-ins. If you need to install a different bit-version of Studio One, you can do so by downloading the desired version from your my.presonus.com account under My Products>Software>Studio One.

4.  Please click the icon of the wrench in the browser window, at the top, right-hand corner of the window, to open the plug-in manager.  Make sure that there is a white dot next to the plug-in, if it shows up in the list.  

5.  If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.
...