Questions & Answers

VST 2.4 Plugin Support Crash - OSX Sierra related?

+1 vote
526 views
asked Nov 4, 2016 in Studio One 3 by kvadivelu_88 (160 points)
edited Nov 4, 2016 by kvadivelu_88

Ever since I've tried to open up Studio One 3 it freezes at "Starting VST 2.4 Plug-In Support..." for over a minute, followed by a Soundtoys (PrimalTap) crash. I've checked if Soundtoys is compatible with OSX Sierra and Studio One 3, and it is. I assumed it was to do with a particular plugin at first so I decided to transfer all plugins to the desktop and then reopen, however it still goes about doing the same thing...

Any ideas? If you need any more information let me know.

MacBook Pro (Retina, 15-inch, Late 2013)

Processor - 2GHz Intel Core i7

Memory 8GB 1600 MHz DDR3

Graphics Intel Iris Pro 1536MB

macOS Sierra Version 10:12:1

Studio One 3.3.1 Build 39379

Focusrite Scarlett 2i2

1 Answer

0 votes
answered Apr 17, 2017 by Jamesrhone1 (199,670 points)
 
Best answer
Please go to Macintosh HD\Library\Audio\Plug-ins.

Copy the contents of the VST and VST3 folders to respective folders on your desktop so that the original folders are empty.

Open S1 and test for the issue again. Add your plug-ins back to the respective folders a few at a time until you can identify the one that is causing the crash.

Most plug-ins on OS X have multiple versions, meaning a plug may have an AU, a VST, and a VST3. If one of the VST/VST3 versions are problematic, remove it from the plug-ins folder and use the version that does work.

If you discover the VST/VST3 is problematic but does not have and AU version, you will then want to contact the manufacturer of the plug-in for information about compatibility, updates, and known issues.
...