Questions & Answers

Pads do not change colour/ turn off while using in Studio One (v4)/ Pad-colour is non-responsive

+5 votes
asked Jan 10, 2019 in Atom Pad Controllers by bjoernbraunschweig (210 points) 1 flag
Hello everyone,
I recently bought an ATOM-Midi-Controller and was very happy with it. For a few hours. After a while the pads did not change colours anymore. Neither when I went into sequencing mode, normal editor-mode nor did they light up in different colours, when changing sets in Impact XT. When a set is changed, the main 16 pads simply turn off (colourwise, not anything else [I think]). Also do the pads - none of them - respond to touch by a slight change of colour intensity as they did, when I first used the ATOM.

I tried deleting the settings files (appData -> roaming and so in), I tried reinstalling StudioOne, reinstalling Universal control... When StudioOne starts, the light on top of the ATOM turns from green to blue. So far it does what it should. But the lights of the 16 pads also turn off (as described above). When I go to "Studio One" -> "settings" -> "external hardware" and reconnect the atom, the lights do light up, but they stay in whatever mode they are in at that moment. When changing between editing, sequencing or the midi-Input via Impact XT, they simply turn off again.

No one else ever seemed to have had this problem, since I can't find any forum-thread/-entry with even a remotely similar problem. It is driving me mad. I am quite close to returning it, since it seems to be hardware related. If you have any idea, whatelse I might be able to do, to get the ATOM to do, what it should, I would be really, really happy to hear about!

Thank you so much in advance!

All the best

PS: When I close Studio One, the ATOM goes into a kind of colourchanging frenzy... It seems as if it is going through every change it forgot to display before.

PPS: Using Studio One 4 Artist Edition on a Windows 10 64-Bit, Lenovo Yoga, All Drivers, Firmware- and Software-Updates have been made and are up to date

6 Answers

0 votes
answered Jan 11, 2019 by oscargarza3 (5,120 points)
Hi, please make sure that USB connectivity is not being interrupted by any other device. If you haven't tried already, make sure that ATOM is the only thing plugged in via USB and check to see if it works. Alternatively, you can try using a USB hub. Depending on the computer, a hub can sometimes help to fix any connectivity issues.
+2 votes
answered Feb 5, 2019 by bryandunk (210 points)
I voted this up. I started epxeriencing the same thing today. Unplugging/plugging back in results in the lights being correct for that current setup but if I change anything in S1 the lights don't match up. When I exit S1, the ATOM goes back to blue lights on.
+1 vote
answered Nov 9, 2019 by brandonfrancis (180 points)
I am having this same issue. Ive tried doing everything mentioned above with no luck.
This is the only thread I've found on this topic. Has anyone found a solution?
+1 vote
answered Jan 11 by rcosing (200 points)
edited Jan 20 by rcosing

Hi, was wondering if this was already corrected? I have the exact same issue and I have tried all recommendations mentioned here but problem still persists.

Update - Jan 20, 2020: For folks in PC/Windows 10, finally got it fixed after raising a ticket. Nick from Presonus support advised to update to the latest Windows 10 build, and that fixed the issue. I have to do the update manually (link below) as my PC somehow didnt automatically update, even if I "search for updates" in the settings menu. Hope this helps. 

0 votes
answered Jan 17 by michaelcotter (240 points)
I have the same exact issue! Has anyone found an answer to this yet? I just opened a support ticket, but these comments don't give much hope...
0 votes
answered Jan 23 by bjoernbraunschweig (210 points)

Hello everyone,

I have an update and will lead with a disclaimer: I have not posted these answers, because they do not, I repeat, THEY DO NOT work everytime. I have had this issue now multiple times and found a workaround everytime, but it has been a different one for each time the problem occured. I will integrate the two suggestions (below) into this "review of hacks", if you will:

Changing USB-cable -> didn't work (I figure it is a deep rooted software-issue)

Switching to a USB-hub -> didn't work -> happens both with a hub and without and also with other things plugged in and without

Updating windows (forcing update manually) -> worked once, when windows was way out of date (one month no updates) but had no effect other times

Downgrading Universal-Control -> worked twice -> downgrading to an earlier version (either by button inside the program or reinstallation of an older version) and then updating to the newest one again

Reinstalling Studio One -> didn't work -> I tried this every time, it never once worked, which makes me think, that this is a deep rooted driver related problem

Downgrading Studio One -> worked once -> tried this also every time (downgrading to an earlier version, where it worked), but since it never started after an update, it seems not to be related

Updating Studio One -> worked once -> also tried downgrading and then updating again every time..

My usual routine whenever it occurs is: 1. downngrading, then updating Universal Control, 2. Downgrading, then updating StudioOne, 3. Updating Windows, 4. Reinstalling StudioOne. That way I move from least to most invasive with the hopes of any of the earlier steps catching and fixing that bug. All in all I would still recommend the ATOM, but this is one heavily annoying (since it is reoccuring) problem. I hope this helps some, but like I said: It could be any of the above, but it could also happen that nothing works.

All the best

PS: Since this is only happening to so few people, I am actually beginning to think, that we have received faulty ATOMs