Questions & Answers

Remember/Save detachment of MIDI editor

+1 vote
110 views
asked Sep 24 in MIDI Editing by fl16 (700 points)
edited Sep 24 by fl16
For some of us (keyboard players specifically) it only makes sense to have the MIDI editor detached and maximized to be able to see 5 octaves, however Studio One doesn't remember that your MIDI editor was detached in your last session. It only remembers  it, if you save the project with the MIDI editor open. If you save the project after closing the MIDI editor because, let's say, you have only one screen and you need to adjust gain levels in the mixing window, you are screwed....

So almost every time that we open Studio one we have to click on the arrow to re-detach the MIDI editor.

Please Presonus, save us from this little inconvenience.

10 Answers

0 votes
answered Sep 24 by colinotoole (6,050 points)
I must say, I don't get the behaviour you describe. After saving a song and reopening it, my editor is exactly where and how I left it even if it it had been closed before saving, say, to access the mixer. {hand on chin emoji - LOL}.
0 votes
answered Sep 24 by fl16 (700 points)
edited Sep 24 by fl16

Oh lucky you!

I noticed that you said though "closing and reopening a song" while this occurs when I close Studio One and reopen it.

Here's a video that shows how it doesn't work in my system (Studio One 5.0.2, Windows 10, 64bit):

https://user.fm/files/v2-a47601f9e7211120eeb10eedf0f41ef1/MIDI%20editor%20detachment%20not%20saved.mp4

0 votes
answered Sep 24 by colinotoole (6,050 points)
Hi there. I've just replicated your steps and ..... it's the same for me as before: the window stays where and how it was. Very strange.

Some differences (but I don't think they should matter): You're on v5: I'm on v4; I'm on Windows 7, you 10.

How can I make a video like yours? I'll make one if you are interested.

Cheers.
0 votes
answered Sep 24 by fl16 (700 points)
edited Sep 24 by fl16
Interesting. I used a commercial screen recorder (http://www.zdsoft.com/downloads.html). I don't know if there is a demo you can use for free.
0 votes
answered Sep 24 by colinotoole (6,050 points)
Hi. I've now made a video for you; but I've no clue how to post it in the answer - LOL.
0 votes
answered Sep 24 by fl16 (700 points)
Maybe use https://wetransfer.com/ to upload and link it?
0 votes
answered Sep 24 by colinotoole (6,050 points)
Hi.

Ok: So, you'll have to download it from this link (it's called 'test'):

https://we.tl/t-TGbOWVdEKc

Let me know your thoughts on it.

Cheers.
+1 vote
answered Sep 24 by fl16 (700 points)
It looks like a bug in Studio One 5 then. I've reported this in a support ticket and I was told they will pass it to the Development Team!
0 votes
answered Sep 24 by colinotoole (6,050 points)
Cool, thanks for letting me know. Hope it gets sorted.
0 votes
answered Sep 25 by jazzundso (96,320 points)
Indeed this sounds like a bug. Hopefully, this can be localized and the developers can take a look at it.
...