Questions & Answers

The "Universal Control" App... It Doesn't Control a Thing. Can't see my Atom, can't check firmware for Studio 26C

0 votes
57 views
asked Oct 23 in Atom Pad Controllers by chrissederqvist1 (2,300 points)
The Universal Control App Is Dead

Earlier, I could se both my Studio 26C Audio Interface and my Atom Pad Controller, interact with the app (like right-click on a device and get a contextual response, at least SELECT a device) then I'd check for firmware upgrades once in a while.

Lately I've noticed that the Atom doesn't longer show up, and also the Studio 26C is not possible to select for checking or reinstalling firmware or nothing. Now today I've tried scrubbing every last file of both Studio One, AND the UC app, including the ones in /Library and ~/Library,  but, still, after reboot, reinstall, reboot, change cables, same sh*t.

I'm out of options.

This app now just sits there looking stupid. It does absolutely NOTHING. The menu entries checks for UC updates, but fails to recognize the two devices it's supposed to update and "control". Not able to adjust the Audio Format, like before either.

I've tried everything.
Either this is a bug in macOS Catalina (wouldn't be the first), or the bugs are YOURS PreSonus!
If this doesn't get better, I'm selling my PreSonus plastic gear and going back to the real things... Never liked the Atom anyway.

My Current Setup:

PreSonus_UniversalControl_v3_3_0_59348
PreSonus Studio One 5 5.1.0.61423
Model Name:    MacBook Pro
Model Identifier:    MacBookPro16,1
Processor Name:    6-Core Intel Core i7
Processor Speed:    2,6 GHz
Memory:    16 GB 2667 MHz DDR4
GPU: AMD Radeon Pro 5300M 4 GB

Please log in or register to answer this question.

...