Questions & Answers

Plugin UI Zooming/Scaling for 4k (Retina) Monitors

+138 votes
2,457 views
asked Apr 2, 2016 in Look and Feel by Funkybot (20,030 points)
edited Apr 16, 2016 by Funkybot
Having recently bought a laptop with a 4k monitor, it would be nice if S1 offered the ability to zoom/scale up plugin UI's. A blurry/larger UI would be preferable to something too small to effectively use without having to resort to other zooming workarounds. A feature like this would obviously be a workaround for plugin UI's that don't offer a scaling feature, but would be a good short-term solution until plugin developers get to updating their code, as well as for plugins that don't.

14 Answers

0 votes
answered May 20, 2016 by jpettit (11,080 points)
Would be interesting to find out how they do it.

If you change your scaling on Win 10 OS to say %200 do the other DAWs follow the scale correctly or are they  much bigger?
+1 vote
answered May 20, 2016 by Funkybot (20,030 points)
There's already an open request for this here: http://answers.presonus.com/7151/plugin-ui-zooming-scaling-for-4k-retina-monitors?show=7151#q7151

It even uses a lot of the same tags.
+18 votes
answered May 20, 2016 by renedale (420 points)
WE NEED THIS!
+16 votes
answered Jun 27, 2016 by jsljustin (390 points)
edited Jun 27, 2016 by jsljustin
I second this. Am using a 2k monitor (2560 X 1440), and even with a zoom set (125% in the old windows 8 terms) in Windows, most plugins are too small, fonts are too small to be readable without severe eye strain.

Really need this for 2k and 4k monitors for most plugins to be useable I think.

Thanks.

[Edit] - just read elsewhere here that no matter what scaling you use in Windows, the plugins in Studio One 3 (under high DPI mode) never scale, so plugins UI will almost always be too small in S1 V3 on a high DPI display currently.
+17 votes
answered Aug 14, 2016 by c-wave (930 points)
The reality of it is that in Studio One (v. 3.2.3) no matter what you do with Windows scaling factor (v. 8/10) you can't change the **plugin** resolution (scale) in Studio One. It only affects the main GUI, plugins are stuck at 100% no matter what you do with Windows scaling factor, and it won't help saying that hey others couldn't do it either because guess what: BITWIG DID. This is a very small company with a handful of genius developers: https://www.bitwig.com/en/bitwig-studio.html (and yes I know that Studio One devs are no less smart).

They even have the the scaling factor independent of Windows; So you don't even have to go to Windows to change the scale; you can simply change the scale from within the prefs. dialog of Bitwig Studio, and it will change the scale of the main gui and the plugins and everything looks very CRISP. Check it out yourself: https://www.bitwig.com/en/download.html

I suggest even having a separate scale factor for main GUI from the one one used for plugins.. that would make everyone happy!

Thanks.
+6 votes
answered Dec 17, 2016 by bkrodgers (280 points)
While turning off high DPI mode in S1 helps with the plugins for me,  it makes S1 itself look very fuzzy.  I'd really like to see the ability to scale plugins while S1 is in High DPI mode.
+10 votes
answered Feb 16, 2017 by jasonnottingham (500 points)
Reminder: we still need this!
0 votes
answered Jul 10, 2017 by benjaminaalund (210 points)
I use Bitwig besides S1 and VST scaling works perfectly on my 4K resolution laptop so it is indeed possible to scale these plugins in High DPI mode.  Running resolutions higher than 1920x1080 is kind of a thing today so it would really be awesome to see this feature in S1 soon
+5 votes
answered Jul 11, 2017 by emptyset (380 points)
We need to have VST's larger on the screen independent of the Windows scaling factor.
0 votes
answered Sep 30, 2017 by Scoox (8,520 points)
Reaper and Bitwig both scale plugins correctly. They also provide bit bridge. I hope Presonus doesn't just dismiss such plugins as "legacy" and ignore the whole issue.

Personally I find high DPI to be utterly pointless for most people except professional graphics designers. For me, the drawbacks of high DPI laptop displays far outweigh the benefits, and so far it's been an uphill battle just trying to get things to work the way they used to.
+2 votes
answered Nov 2, 2017 by Ausgeno (210 points)
Hey, just got myself a 4K monitor and this issue is now affecting me too. Most of my VSTs are unusably small.

Can't believe this has been a feature request for over a year - please Presonus give us the option to 2X scale our VSTs so your DAW can be used on modern monitors!
+4 votes
answered Dec 18, 2017 by simonhughes2 (220 points)
edited Dec 18, 2017 by simonhughes2

WINDOWS 10 ONLY

Although I don't have a 4K monitor, I do run Studio One 3 on a Surface Pro 3 (2160x1440 screen) and suffered this same problem which I have overcome. I can only comment with respect to Kontakt, Reaktor, Maschine 2 and some Waves plug-ins but the steps below solved the problem with these for me.

Current setup

Surface Pro 3 running Windows 10 Creators Update set to max resolution of 2160x1440 with desktop window scaling set to 200% (this is my normal setup for everyday life). 

Screenshot of Studio One running Kontakt BEFORE:

Screenshot of Studio One running Kontakt AFTER:

The fix is to change the Windows program compatibility settings for Studio One as shown below to override high DPI and set to System (Application isn't sufficient). Easiest way to get there for me was to right click on the Studio One icon on the taskbar when it's running, right click again on Studio One from the menu popup and then select Properties. Obviously, you'll then have to restart Studio One

As I said, this also worked for me with Reaktor, Maschine 2 and a Waves plugin.

You may find that you need to resize your plugin in Studio One to its smallest before you make the change otherwise you might not be able to reach the edges/corners to resize afterwards as they are offscreen (this happened to me with Kontakt). In fact, although Maschine works, even at view size set to Small it still overshoots the screen by about 1cm.

As a bonus, the same solution when applied to Notion 6 sorts out the plug-in size problem there as well.

Of course, I agree with everyone else that Studio One should, at a minimum,  apply the same scaling it applies to the rest of the app to plug-ins as well but a custom definable one for each one would be even better (this plug-in problem also does not happen in Cubase 9.5). 

Anyway, hopefully this might help a few other people.

0 votes
answered Apr 16 by vincentkaye (180 points)
I recently purchased S1 pro and it looks great on my 4k monitors except my 3rd party plugins were tiny but using the application specific settings described below it now displays correctly.   I would hope this becomes a sticky as it took me hours to find this particular thread to make the tweaks.
+1 vote
answered Jul 29 by maximusrapido (480 points)
Changing the Studio One.exe properties (override Hi DPI scaling) is not a valid solution. When you do that it blurs Studio One itself.

I have a Dell 4K monitor with Windows 10 set to 150% scaling. This setting is perfect for all my applications, but not in Studio One.

1/ if "override Hi DPI scaling" is NOT set in Studio One.exe properties -> Studio One scales perfectly at 150% (following windows 10 setting), but the third party VST are NOT scaled, they remain at 100% and look tiny. In fact whatever the scaling in windows 10 (125%, 150%, 175%, 200%) the VSTs remain the same, they do not scale: Windows scaling is ignored by the VSTs

2/ if "override Hi DPI scaling" IS set in Studio One.exe properties -> third party VST ARE scaled correctly (150% in my case) BUT Studio One UI is blurred, resolution of the UI is downgraded, text is difficult to read : not acceptable

In short you have to choose between: Studio displayed correctly and tiny VSTs or VSTs displayed correctly by with a blurred Studio One UI. This is not acceptable. I have searched this forum and the issue of Studio One compatibility with Hi Res / 4K monitors on Windows has been described in several threads and has been going on for several years now. I can't believe that Studio One 4 has been released without resolving it.

The other DAWs I know, Ableton Live 10 and Cubase 9, both behave correctly, VSTs are scaled correctly according to Windows 10 setting and everything looks OK.

I love Studio One but this issue (+ no support of Native Instrument NKS) prevents me from switching to Studio One.

Presonus, please do something about it, this is becoming ridiculous!
...