Questions & Answers

universal control 1.73 will not start on os x 10.11.4

0 votes
516 views
asked Apr 7, 2016 in Classic Mixers by fpclex (120 points)
edited Apr 7, 2016 by fpclex
Macbook Pro (Mid 2015 16GB retina display)

OS x 10.11.4

StudioLive 16.4.2 mixer - works fine with windows XP and studioLive.

Installed UC from Universal_Control_173_5742.dmg. When I go to LaunchPad and start UC I get an error box with:

The software was not installed correctly. Device DLLs not found. Please re-install and try again.

Did full manual uninstall as noted in some support document and re-installed. Still same problem. Happens with or without mixer attached to thunderbolt port.

Here's part of the crash report. Looks like a SIGSEGV:

Process:               Universal Control [805]
Path:                  /Applications/Universal Control.app/Contents/MacOS/Universal Control
Identifier:            com.presonus.controlpanel
Version:               1.7.3 Build 5742 (1000)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Universal Control [805]
User ID:               502

Date/Time:             2016-04-07 16:46:40.098 -0400
OS Version:            Mac OS X 10.11.4 (15E65)
Report Version:        11
Anonymous UUID:        BF565976-4A61-9FE9-4915-14FDC6E8B31D

Sleep/Wake UUID:       DB6EF8CF-78B3-4117-9F8D-725C02AA48BE

Time Awake Since Boot: 2500 seconds
Time Since Wake:       1200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0:
-->
    __TEXT                 0000000100000000-000000010067f000 [ 6652K] r-x/rwx SM=COW  /Applications/Universal Control.app/Contents/MacOS/Universal Control

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   ???                               000000000000000000 0 + 0
1   com.presonus.cclgui               0x000000010082688f 0x100762000 + 805007
2   com.presonus.cclgui               0x00000001008269da 0x100762000 + 805338
3   com.presonus.controlpanel         0x000000010005e5d8 0x100000000 + 386520
4   com.presonus.controlpanel         0x0000000100002441 0x100000000 + 9281
5   com.presonus.controlpanel         0x0000000100001c69 0x100000000 + 7273
6   com.presonus.controlpanel         0x0000000100001b14 start + 52

1 Answer

0 votes
answered Apr 10, 2016 by SwitchBack (2,520 points)

Apparently it can be a bit of a job to get UC to install correctly under El Capitain. Did you find these instructions by the PreSonus support team?: http://support.presonus.com/entries/105171633-Mac-OS-X-10-11-El-Capitan-Compatibility-Statement

...