Questions & Answers

Why does Studio One 3.5 crash on OS X loading built in audio device?

+1 vote
492 views
asked May 26, 2017 in Studio One 3 by PreSonuSupt4 (154,050 points)
Why do I get a crash in OS X 10.9.5 in Studio One 3.5 on "loading audio device".    It asks if I want to try to open the built-in device that failed before but when I click Yes or No it crashes.

6 Answers

–4 votes
answered May 26, 2017 by PreSonuSupt4 (154,050 points)
 
Best answer
This issue has been logged with our development team in hopes that it will be addressed in a future update.  Should the issue be addressed in an update, you will see it in the release notes of that update.

As a workaround, you can create an aggregate device on your Mac that incorporates your built-in output with your built-in microphone.  Here is a link from Apple that explains how to create an aggregate device.

https://support.apple.com/en-us/HT202000

Once you have created the aggregate device in the Audio MIDI Setup, the first time that you launch Studio One it will crash.  The second time that you launch Studio One, you can tell the program not to use the built-in output, and it will automatically switch to the aggregate device.  Please let tech support know if you have any problems.
0 votes
answered May 27, 2017 by alemass73 (350 points)
The workaround didn't work for me.

Hope in future update.
0 votes
answered Jun 6, 2017 by redonestudioone (140 points)
workaround didn't help here as well. Looks like I have to go back to 3.3, change the audio device and update again?
0 votes
answered Jun 7, 2017 by Logen2012 (290 points)
Unfortunately, 3.5 won't work on the Macbook Pro. Same issue as below "Failed to load built in audio" then crashes. Work around doesn't work.

Did not have any problem installing 3.5 on my Mac Pro, but it will not work on the laptop. Going to have to go back to the previous version on both now until the issue is fixed. Hoping to see that fix very soon.. Please.
0 votes
answered Jun 21, 2017 by alexanderdelicata (370 points)
doesnt work for me either. had to revert to 3.3. Anybody now when there will be a 3.5.1 update that might fix this??
0 votes
answered Jul 15, 2017 by Logen2012 (290 points)

At least for me, this issue has been resolved with the update 3.5.1.43560. If you were having issues with 3.5 crashing on a MacBook Pro, installing this update fixed the problem on mine. It's now working as it should. Thank you Presonus.

...