Questions & Answers

Recording Virtual Instruments

0 votes
74 views
asked Jul 9 in Studio One 3 by philparaggio (150 points)
edited Jul 9 by philparaggio
Same problem which I think the last writer described; In my case I am taking a virtual instrument from 3.5.1 library and dropping in my workspace.  New track is created and I can play and monitor the virtual instrument on computer; in this case I am just clicking around with a mouse but I have full control over the instrument.  I arm and record the track - timeline lights up and rolls along.  I see input levels at on screen mixer but nothing indicating input signal on the actual track which I think I'm recording.

When I stop recording, the track is still there but empty timeline for that track.

Recording via USB interface is fine and recording via single USB condenser mic is also fine.  

I also started a new song and chose Instrument Set which loads 4 tracks of ready to play instruments.  I can bring up those instruments, arm the related track; start record and play on screen.  I get the same result; when I stop recording the track is empty.

Thanks for any feedback.

1 Answer

0 votes
answered Jul 10 by brianmeisner1 (128,390 points)
 
Best answer
It sounds like your MIDI device is not sending data to Studio One.  You will want to go into Studio One>Options (Preferences on a Mac)>External Devices.  Locate your MIDI device, double-click it and check the box to make it your default instrument.  If you have already started a song, press the letter "i" at the top left-hand corner of the screen to view the Inspector window for your track.  Make sure the input is set to the MIDI device that you wish to use.  You will also want to open the MIDI Monitor by clicking the icon of the 5-pin MIDI cable at the bottom left-hand corner of the screen.  With this window open, press some keys on your MIDI controller and verify that you are receiving MIDI data.  If you are not, check your MIDI ports in the External Device list.  If the problem persists, please try uninstalling/re-installing Studio One.  You will then want to try removing your settings files from the program and re-configure your MIDI device.  Here are instructions for removing your settings files.

1.  Go to Help>Open Settings folder.

2.  Copy the contents of the folder over to a folder on your desktop.

3.  Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

4.  Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

5.  Test to see if the problem is resolved.  If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.  

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.
...