Questions & Answers

Why is my Macro toolbar not working?

+1 vote
473 views
asked Nov 22, 2016 in Studio One 3 by ogsproductions1 (210 points)
I have upgraded from Studio One Artist to Pro today and cannot seem to get the Macro toolbar to work.
The extension is installed. The toolbar appears when activating it but it remains blank.
The macro organiser exists and from the tutorials i have created some personal commands but nothing shows in the toolbar. When right clicking on the toolbar the only option that appears is regards to alignment.
I have read through all the supplied information but to no avail

3 Answers

+2 votes
answered Apr 10, 2017 by brianmeisner1 (193,360 points)
 
Best answer
If you have not created any macros yet, you will want to go into Documents>Studio One>Macros and delete the commandbar.xml file.  Once you close and re-open Studio One, it should resolve your issue.  If it does not, try deleting the entire macro folder and then re-open Studio One.  If you are still having a problem, please try deleting your settings files.  Here are instructions:

1.  Go to Help>Open Settings folder.

2.  Copy the contents of the folder over to a folder on your desktop.

3.  Close S1 and delete the contents of the settings folder with the exception of the user.license file as well as the "Extensions" folder.

4.  Open S1 and go to Studio One>Options (Preferences on a Mac) to reconfigure your settings.

5.  Test to see if the problem is resolved.  If it is not, please feel free to copy your settings files back over from the backup that you created in step 2.  

*If you are missing presets or Sound Sets after doing this, simply double-click one of your Sound Sets under Documents>Studio One>Sound Sets.
0 votes
answered Apr 10, 2017 by ogsproductions1 (210 points)
Deleted the commandbar file and boom it worked!
Many thanks!
0 votes
answered Aug 19, 2017 by El Caldero (360 points)
The second option brianmeisner1 gave worked to me. Macros folder was reconstructed automaticaly when I opened SO again. Also commandbar.xlm file was remade when I anabled Macro bar in SO.

Thanks a lot!

Leo
...