Questions & Answers

Why am I losing midi notes when live recording my Roland electronic drum kit in Studio One 3

0 votes
asked Mar 24, 2017 in Studio One 3 by chedcheddles (170 points)
Hi, I am trying to record midi drum data played live from my Roland TD-25 kv drum module into Studio One ver Artist.

The problem is that when I play 16th's on the hi-hat only 3 or 4 of the 16 beats is making it across to the recorded track. The snare, kick and toms are o.k as long as they are not played to quickly. I am pretty new to this DAW and imagine it's a setting somewhere. I searched various forums but cannot find an answer.

The midi data is coming out of my drum module, into a PreSonus AudioBox iTwo firmware v1.32

Any advice or suggestions would be gratefully received.

3 Answers

+1 vote
answered Mar 26, 2017 by adewalker (390 points)

I can't answer the specific question, but I would recommend recording audio and MIDI direct from the TD-25 module to Studio One. This works very well for me.

To do this, you need to do the following:

1. If you haven't done so already, download the TD-25 USB driver appropriate for your OS from here:

2. Install the Roland driver as per their instructions (included in the download).

3. The TD-25 will then act as an audio interface selectable from within Studio One (assuming the TD-25 is switched on and connected via USB to your computer).

4. In Studio One, select the TD-25 interface in Audio Setup (Preferences window), and configure the Input matrix. The TD-25 only has stereo L+R out, so there's only one stereo input to set up.

5. Then create an External Instrument (Studio One Preferences > External Devices). Click Add, which will launch a dialog box. Fill in the info in the dialog box: give it a device name, and select TD-25 in the Receive From and Send To dropdowns. By default, the TD-25 transmits on Midi channel 1, so select Channel 1 in the Midi channels section. I leave all the check boxes unchecked and the CC Automation interval at its default of 10ms. Save this configuration. If you want to use a different MIdi channel, you can change this in the TD-25 module's Setup screens and configure the External Device dialog box accordingly.

6. In your Studio One Song, add an Audio Track (stereo) with TD-25 Input L+R selected.

7. Add an Instrument Track and configure its input as the TD-25 External Device (which you created above).

8. Remember, the TD-25 is now your interface, so plug your headphones into the TD-25 and monitor what you're playing to, and the drums, using the module's front panel Backing and Master volume knobs.

9. Record enable the two tracks in Studio One (the Audio and Instrument tracks mentioned earlier) and you should be good to go. The TD-25's audio will be recorded to the Audio track, and the MIDI to the Instrument track.

I always have my backing track, or whatever I'm playing along to, already in Studio One, and found that I needed to change the TD-25's USB levels in the TD-25 module: SETUP > AUDIO to get a decent audio record level (using Roland's kits). You may need to play around with this a bit to get the Output level to what you want without clipping.

This may all seem a bit of a hassle, but once it's setup, it's good to go whenever you need to record te Roland.

Hope this helps.

0 votes
answered Mar 25, 2017 by Nick Bell (140 points)
Not an answer. I have been trying to get my TD-15 & TD-20 to record midi in but I'm not getting anything to show as actual midi data. I was just wounding what you have for settings when your recording the data. Also if you have to adjust and of the midi settings on the Roland kit it's self?
0 votes
answered Mar 25, 2017 by chedcheddles (170 points)
I have the TD25 drum module midi out cable plugged into the midi in port of the AudioBox iTwo. I just set up an instrument track in Studio 1 to record the midi and ran a second audio cable from the mono audio output of the drum module into the AudioBox itwo and setup an audio track to record the sound from the drum module to help sync the midi up afterwards.
So I am recording both the midi and audio at the same time. Obviously there is some terrible latency so to try and get round this the headphones plug into the socket on the AudioBox iTwo, not the drum module, you can use the output volume and mix dial on the iTwo box and hear the real audio you are playing. If you turn down the output fader on the midi track in the mix window it gets rid of the latency problem. It also means you can play along to the click and anything else routed out of Studio 1. Like I said I am pretty knew to all this and I am sure there is a better way of doing it.

The settings on my drum module are the defaults for the midi stuff, I have not changed anything. The midi track is just the stadium kit that I think comes as a default with Studio 1 but you could use whatever. Basically I have just fed midi into the AudioBox iTwo and it seems to work except for my problem of data being dropped when anything gets played too quickly.

Hope that helps