Questions & Answers

getting Roland TD-30 to work with NOTION 6

0 votes
32 views
asked Aug 28 in Notion by kimokeomokana (390 points)
I am able to use mt Roland TD-30 with every piece of software on my MAC but cannot get it to be recognized in NOTION.

all the preferences under MIDI are set to TD-30.

No matter what approach I take, NOTION will not record  hits on a drum staff.

I have Addictive Drums also and it works flawlessly with NOTION in playback mode. Also in stand alone AD recognizes the Roland just fine.

When I create a midi staff, or a drum staff, or a VST Addictive Drum staff, it will not recognize the TD-30, WHICH IS SET UP TO USE THE MIDI GM MAPPING.  I have tried all channels. All ports. Nothing works. NOTION should see it as a MIDI piano Keyboard, but does not.

1 Answer

0 votes
answered Aug 28 by brianmeisner1 (128,520 points)
 
Best answer

If you are having a problem connecting a MIDI device, please take a look at the following information.  As you have also submitted a support ticket, we can continue to troubleshoot there.

Mac:

  •  Make sure that all of your cable connections are correct.  If you are using a 5-pin MIDI cable, make sure that the "out" on your Keyboard is connected to the "in" on your MIDI interface.  
  • Open Notion and go to Notion>Preferences, MIDI.  From here, you want to set your input port to to your MIDI controller or MIDI interface.  If you have a problem, you might want to try "All."  If the keyboard is working correctly, you should be able to here the instrument that you have the cursor on play back from the MIDI keyboard.  Try pressing the record button in the transport bar and start your recording.  You should see the MIDI data entered into the staff.
  • If you are still having a problem, you may need to go to Notion>Preferences, General and set the NTempo channel to "None." 
  • If you still cannot resolve the issue, you may need to click on "Go" in the Finder menu bar and hold down the "option" key until the library shows up.  Select "Library" and go to "Preferences."  Delete any files that start with "com.notionmusic."  These are preferences for the program and will be recreated when you open the program the next time.
  • If you need to verify that your keyboard is sending MIDI data to your computer, you can download and install a free program called "MIDI Monitor."  http://www.snoize.com/MIDIMonitor/  Once installed, you can open MIDI Monitor and set your MIDI input device.  You should be able to capture the MIDI data coming into your MIDI ports on your computer to see if there is a problem with your device, cables, etc.

Windows:

  • Make sure that all of your cable connections are correct.  If you are using a 5-pin MIDI cable, make sure that the "out" on your Keyboard is connected to the "in" on your MIDI interface. 
  • Open Notion and go to File>Preferences, MIDI.  From here, you want to set your input port to to your MIDI controller or MIDI interface.
  • If you are still having a problem, you may need to go to File>Preferences, General and set the NTempo channel to "None." 
  • A common problem on Windows machines is that the USB port/s become wrapped.  You might want to try a different USB port or reboot your computer.  
  • If you need to verify that your keyboard is sending MIDI data to your computer, you can download and install a free program called "MIDI Ox."  http://www.midiox.com/ Once installed, you can open MIDI Ox and set your MIDI input device.  You should be able to capture the MIDI data coming into your MIDI ports on your computer to see if there is a problem with your device, cables, etc.  If you cannot get the MIDI data to flow, you may need to contact the manufacturer of your MIDI keyboard.  For problems with Yamaha keyboards, you can call 714-522-9000.  Some Yamaha keyboards require that you use a specific MIDI interface with a specific keyboard.
...