Questions & Answers

S1 plug ins scanning process : how to avoid the scanning of the default plug ins directory in a MAC installation ?

0 votes
1,627 views
asked Feb 16, 2017 in Studio One Feature Requests by angelomariasalvati (230 points)

Hi,  I've tried to do all the the things that S1 support suggested to me but the problem is anyway unsolved. S1 scans ANYWAY the default plugin dir in the MAC with or without the flag checked or unchecked in the preferences and ANYWAY, even if the path is written or not in the preferences, S1 scans that default plug in path of a MAC installation. I ask one thing: in which file that S1 reads at the start the path to be scanned is written ? I will cancel it !  Only if I rename the default plug in dir I can avoid the scanning process by S1 and it starts correctly. 
I think that the solution - until this bug will be corrected - could be to rename the default plug in dir avoiding the S1 plug ins scanning process and to configure the new address in the the other DAWS that I use

Could you correct this bug in S1 ?
Regards
Angelo

1 Answer

0 votes
answered Feb 16, 2017 by Jamesrhone1 (199,690 points)
 
Best answer

Please don't rename system Plugin folders (Component, VST, etc) on OS X, the permissions for that folder will change and can create issues when those folder names are set back to their default name. 

Creating a new folder and moving plug-ins from the system plug-ins folder to that folder is safer than renaming the folder. Then, these new folders can be added to Studio One to scan. 

Note: The latest support ticket that was submitted on this has been answered.


If anyone has an issue with start up scanning on OS X, this is the correct way to set Studio One not to scan. 

  1. Go into Library/Audio/Plugins/VST and remove the problematic plugins so Studio One can start.
  2. Launch Studio One, go to Studio One>Preferences>Locations>VST Plugins and check the box to scan at startup.
  3. Close and re-open Studio One to verify that it is not crashing on you.
  4. In Studio One, go into Studio One>Preferences>Locations>VST Plugins and uncheck the box to scan at startup. This will prevent Studio One from scanning the plugins folder in the future.
  5. Add your problematic plugins back to the VST directory.
...