Questions & Answers

Kontakt performance issues with low latency monitoring

+3 votes
603 views
asked Sep 25, 2017 in Studio One 3 by alancloughley (2,300 points)
I've upgraded from a really old i7 2Ghz laptop to a Skull Canyon i7 base 2.6GHz and has turbo up to 3.5. I added 16Gb DDR4 memory and 2 Samsung Evo 960 drives so assumed it would handle a 16 track song mainly audio with a handful of VSTs, Kontakt drums, strings and a few synths. I bought a Quantum as I thought that would give me reasonable perormance using low latency monitoring with max protection set for dropouts. I run Slate plugs on most channels and a couple of reverbs it's all good until I select Kontakt Abbey Road drums track. The zero latency kicks in for the channel and the S1 performance meter shoots up to 100% meaning I can't easily record anything further on the track. CPU is sitting about 20% in windows and similar for S1 performance until drum track is selected. I've tried increasing buffers to 128 and still have some issues and 256 gets a little laggy. Kontakt seems a real hog in Studio One as in Ableton I can easily run 4 instances of Abbey Drums even at lower buffer settings S1 struggles with one on a small project. Anyone know of any settings in S1 or Kontakt that might improve performance or is the Skull Canyon just not great for low latency? I wasn't expecting miracles but the old laptop did fairly well with Kontakt via a usb 2.0 interface so thought this would give me a little bit more of a performance bump. I've tried various memory preload and cpu settings in Kontakt config with no success.

4 Answers

0 votes
answered Oct 6, 2017 by alancloughley (2,300 points)
 
Best answer
Found a solution, just don't use the new low latency features, set the dropout protection to minimum and device block size to something reasonable, disable low latency monitoring of virtual instruments, stay away from the green Zs and everything works loads better with VSTs. Same with VST insert plugins, all works great. Looks like the new low latency features don't work well with VSTs. Performance meter in Studio One goes from about 95% to about 20%. Should have been an obvious thing to try but I assumed it would make things worse switching this all off. Awesome I can now record 20+ tracks with VSTs plug ins and plenty of Kontakts with no problem.
0 votes
answered Sep 26, 2017 by mikel54 (140 points)
I'm experiencing similar issues using Kontakt Player (5.7) and Friedlander Violin. If I set Dropout protection to anything lower than 'High' I get a lot of crackling noises while I am playing my connected midi keyboard controller. The crackling also occurs on playback. so in order to eliminate the crackling I have to set dropout protection to 'High' which increases the latency to the point that I cannot play the midi keyboard controller. I have a brand new PC, Intel Core i7-6850K 3.6GHz, Six-Core Processor with 15MB cache, 16Gig of Ram, OS (Windows 10 Home) installed on SSD and data on 1TByte hard drive, a very fast computer. My audio interface is a Midas M32R connected via USB set at 48.0kHz. My midi keyboard controller is connected via a M-Audio Uno (USB/Midi interface).
0 votes
answered Sep 26, 2017 by alancloughley (2,300 points)
Hi mikel54, sorry to hear that! My box is an Intel NUC not a full desktop so I'd imagine your machine should be performing a lot better even with USB but in case you've missed it AFAIK (and this might be the problem!) there's two tabs in OPTIONS  > AUDIO SETTINGS for Studio one, the second tab (Processing) where you pick the dropout protection sets the buffer size for tracks that aren't record enabled. This is supposed to mean that tracks which aren't record enabled in a project run at a high buffer setting of 2048 (for Maximum) and 1024 (for High) taking the load off the PC. The first tab (Audio Device) in Audio settings is where you select the low latency buffer setting by selecting the Device block size for record enabled tracks. This should mean the PC only has to handle low latency for virtual instruments and audio for record enabled tracks. To enable low latency for virtual instruments though you have to select the check box on the Processing tab called "Enable low latency monitoring for instruments" you've probably already done that but if not select that check box on the second tab and set the device block size on the first tab to something around 64 or 128 (or even 256 if it's still popping and cracking!) and see if that helps? If not you've probably got the same issue I have. I only get bad pops and crackles if the CPU is loaded on the other tracks (typical 16 track session a plugin on each track). I think the code for VSTs might not be optimal and hopefully they'll get round to improving performance a little in a future release. It's not far off for my typical projects so hopefully the guys at Presonus will do a little work to fix this soon. The workaround for now for me is to use the menu option to split the drum tracks into individual tracks and transform the tracks to audio although it's still a struggle to add additional drums to a typical 16-20 track project at the moment. It may be my machine needs some further tweaks in the BIOS or in Windows 10 but I've followed most of the common steps to improve performance in Windows and I'm really surprised a 6th Generation Intel CPU with NVMe drives and twice as much RAM as my old laptop is not showing much better performance with heavy Kontakt instruments especially as I'm using the Quantum thunderbolt interface as opposed to USB. I'm up at 8ms audio latency and still getting pops and crackles for virtual instruments. If I go any higher it will affect the audio performance so I'm stuck with having to switch buffer setting on a session and going into laggy VST performance if I want to overdub a virtual instrument! On a positive note the audio performance is pretty good if I don't use VSTs.

The new dropout protection options were supposed to solve all this but it looks like they've more work to do on Studio One on the VST side or the particular machine I have is maybe just a poor latency performer. I'll setup Ableton with a similar track count and FX on both Quantum and my old USB interface and see how it performs to see if it's the machine or something to do with Studio One/Quantum interface/Dropout protection. Shame as this was a really neat idea and I had high hopes, however it's a bit of an epic fail and an expensive one at that, the Focusrite Scarlett range posted better round trip latency at less than half to cost so I'm hoping it's a setting or driver issue of some kind and someone can't point out my stupidity and solve this issue ;)
+1 vote
answered Sep 27, 2017 by alancloughley (2,300 points)
Hi mikel54, I've now tried this in Ableton live with a similar track count and effects on channels on the Quantum. It can easily support two tracks of Kontakt with the Abbey Road drums (and some other Kontakt VST instruments!), 16 audio tracks all with Slate plugins, a reverb send and some FX on the master all stable at 64 device block size it sits about 30% on the Ableton performance meter and similarly in Windows task manager all is stable! Ableton has no dropout protection and all tracks are running at a low latency setting so I'd expect Studio one to be able to manage a fair bit better.

Unfortunately the performance is dreadful in Studio One in comparison. As my machine is capable of low latency playback of VSTs in Ableton even chunky ones like Kontakt it looks like the implementation of dropout protection and low latency with VST instruments and effects in a project is just very poor in Studio One. I tried removing Kontakt by transforming it to an audio track leaving the session with just audio files and no VST instruments (keeping VST plug in effects on the tracks) and it seems to handle the performance a lot better and I can get down to 32 for device block size and 4ms latency, but the Quantum has been unstable and cuts out during tracking and even at 64 it's not always stable. VST effects take a big toll on performance though for selected channels and it's struggling to record with any level of FX on all 8 inputs at one time. Basically at 128 buffer giving 8ms latency it's just about possible to record 8 channels of audio with minimal Slate plugins on each channel although that's full round trip if the values reported are to be believed.

In summary Studio One kinda sucks at running VSTs despite the newly added dropout protection and low latency feature workarounds. Under the hood from what I can see Ableton is massively more efficient at running VSTs so can run more tracks without any tricks to get the most out of it's audio engine. I've raised a support ticket so hopefully Presonus can advise on whether there's some magic settings in Studio One, Windows 10 or my BIOS which will dramatically improve things, I'll let you know if I hear back, I think the solution though is to save up for a shiny new 10 core Intel PC! ;)
...