Questions & Answers

Getting E-Drum Roland TD-30 to work with Studio One 4

0 votes
28 views
asked Dec 4 in Studio One 4 by janineh (120 points)

Computer Make and Model: Dell Inspiron 1700 series

Operating System and Version: Microsoft Windows 8

Hi, I'm trying to get my Roland TD-30 to work with Studio One 4 Professional, but there are a few issues to get this done.
a) If there is only an instrument track created, the notes are saved too fast (entire midi-track is too fast), although I'm playing really slow. When I regulate the tempo by (for example) 50 bmp it is still running way too fast (even when it is on 10 bpm).
b) When I'm creating an instrument track plus an audio track and let them run and record together, the tempo-issue is gone. But here I have the problem that I'm losing midi-notes in the instrument track (audio track is working fine), especially those that come from the HiHat.
c) If I have my preferences in the external device (Roland TD-30) set to "Send To: TD-30" I'm hearing my play twice through my headphones. Maybe because of the latency?
That is why I changed my settings to "Send To: Microsoft GS Wavetable Synth (emulated)".
With this preference I hear my direct play on the TD-30 (headphones are connected to the TD-30). Simultaneously the sound of the Basic Kit from Studio One 4 is outputted on the speakers of my computer.
Actually I'm using these settings:
Preferences --> External Device --> Add Device --> New Keyboard --> Device Model: "New Keyboard"; Manufactuer: Roland; Device Name: TD-30; Midi Channels: All; Receive From: TD-30; Send To: Microsoft GS Wavetable Synth (emulated); No Filter; No Split Channels; No Default Instrument Input.
The Roland TD-30 is connected directly via USB to the computer (no audio box used).
Preferences in a new song:
First Track --> Audio track (stereo); Inputs: L+R (stereo)
Second Track --> Instrumental track --> Browse --> Instruments --> Presence --> Artist Instruments --> Drum Kits --> Basic Kit; Inputs: TD-30; Sends: Main
Hope somebody could help me work this out, I guess it is just a matter of wrong settings that I use.
Thanks a lot
 

Please log in or register to answer this question.

...