Questions & Answers

Duplicate Track WITHOUT REGIONS!

+2 votes
119 views
asked May 29, 2019 in Mixing by akheecubano (510 points)
Apparently, you can only duplicate a track with either

1. the complete track with the regions included, witch is not linked with the duplicated plugin (so u can make changes independently).

2. the track without the regions included, but with the plugins linked to each other like 1 plugin instance.

i want the option number 1 without the regions included, its so messy to duplicate a track and having to select all the regions on that track in order to delete them.

I tried to make a macro, witch went like this:

1. TrackDuplicate (complete)

2.EditSelect All on Tracks

3.EditDelete

now this is very messy, lets say my first track was named Impact 1, and i had a region on that track,

then when i duplicate it with the macro, it makes a duplicate underneath with the region on it ( Impact 2 ),

and it removes the region from the the duplicated one ( Impact 1 ) .

So now the first one is kinda the duplicate.

I would be very pleased if you resolved this issue.

Thanks in advance

4 Answers

0 votes
answered May 30, 2019 by robertgray3 (32,840 points)
Just add a line to the macro that navigates to the “duplicate” track before selecting all and deleting

It’s not a bad idea but there are about 100 features I’d rather see before this one
0 votes
answered May 30, 2019 by vasilykorytov (9,420 points)
edited May 30, 2019 by vasilykorytov
in fact, current `Track|Duplicate' is broken for macros (at least up to 4.5.1 that I verified), it does not transfer focus to a new track(s) as it should.

`Navigation|NextTrack' does not solve this problem as it:

1. breaks the ability to use macro with multiple tracks

2. does not work when the selected track is last one

I've created a support ticket #492441 in February for this, they confirmed this is a bug and they can reproduce it, but no news yet when they're going to fix it.
0 votes
answered Jun 1, 2019 by akheecubano (510 points)
exacly, its a bug. Presonus, please fix this!
0 votes
answered Apr 1 by yairriff (190 points)
Agree, year after - it's still a bug. I've tried to make the same macro, and I somewhat happy that I'm not alone...
...