Questions & Answers

Can Midi be recorded “as you hear it”?

0 votes
144 views
asked Jun 1, 2019 in Studio One 4 by sasarajak (2,670 points)
I hate to say this, but Studio One live midi recording sucks in comparison to other DAWs.
I understand latency and how things work, but, when I record something in Cubase or earlier in Sonar, it always plays back as I was hearing it while recording.
In Studio One the recorded midi gets out of sync (moved in time forward or backwards) and it depends on what plugins are in use in the project as if latency compensation doesn’t work for midi recording. I just don’t get it how I can hear my VSTis in time when playing (I wouldn’t be able to play if it was out of time anyway) but recording is off?

This is not the case in Cubase (or at least I didn’t experience it as yet) and what I hear when recording is what I get on playback.
I hope you get me, also, this topic has been circulating around for years and it doesn’t look like it gets much attention other than generic “latency theory” copy/paste answers

6 Answers

0 votes
answered Jun 1, 2019 by johnellard (3,010 points)
I would try the following:

1. Go into Audio Setup, Preferences, Processing tab, and set Process Precision to Double (64 bit). For some reason, the default setting upon installation of SO is: Single (32 bit).

2. Go into Audio Setup, Preferences, Audio Device tab, set Device Block Size to 256 samples.
0 votes
answered Jun 1, 2019 by sasarajak (2,670 points)
I got all that under control. What bothers me is when I play my midi keyboard i can hear other tracks and play along in time without problems, but when I play back recorded midi it’s completely out of time with the rest of the arrangement.
My point is if S1 can triger vst sounds in time when I play it while recording, why can’t it also record it in same time?

0 votes
answered Jun 1, 2019 by robertgray3 (38,170 points)
What’s the feature in Cubase or Logic that does this called? Input compensation? Anyone know?
–1 vote
answered Jun 1, 2019 by sasarajak (2,670 points)
Studio One has something called track delay but it doesn’t work properly.
As I understand it is supposed to move track in time by the number of milliseconds you type in (positive or negative) but in my case it doesn’t seem to be working properly
–2 votes
answered Jun 6, 2019 by sasarajak (2,670 points)
It looks like no many people actually play their parts but rather copy/paste
0 votes
answered Jul 19 by robertgray3 (38,170 points)

First, double check you don't have Input Quantize enabled. I think it's on by default sometimes, and it's not really the greatest default choice for most people.

Then, you might want to check out this post:

https://forums.presonus.com/viewtopic.php?p=238931#p238931

First of all, since you said most people must "copy/paste", no I play in my parts same as you.

I would not bother to read most of the discussion and skip to the post I linked because so far, the only things that have been consistently measured and demonstrated related to your issue are:

1 - Monitored virtual instruments have some measurable deviation in latency on macOS only. When I say measurable, I mean greater than ~1ms total.

2. The amount of deviation gets bigger with bigger buffer sizes. I only monitor at 64 so I honestly never noticed it until I helped a user do some tests.

3 - The amount of deviation is only audible at a block size >= 256 samples, whether or not you are using Green Z monitoring doesn't seem to affect when it becomes audible.

4 - The amount of deviation gets pretty bad around 512 samples and above. For whatever reason, some users monitor at pretty high block sizes. 

If you're on Windows 10 and experiencing weird issues in your monitored audio then the post above probably does not apply to you and honestly it's probably something other than Studio One that is the issue.

...