Questions & Answers

Faderport won't function w/ current Mac OSX (Mojave), curent MIXBUS 32C, 2014 Mac Mini I5

0 votes
32 views
asked Jan 27 in FaderPort 2018 by mikejoseph3 (120 points)

Hey there, experts! Hope someone here can assist with this challenge. Love(d) my Faderport Classic, but... Got patience? here goes:

Mac, Harrison Mixbus, lots-o-external goodies. I retired my mid-2012 Mac mini due to slower graphics (and glitching due to shared RAM/no separate VRAM), and 'upgraded' to a 2014 Mac mini with IRIS graphics last week (yes, minor but noticeable redraw speed improvement). OSX is Mojave (10.14.6).

Current 2014 Mac mini specs: 16 Gig RAM, internal 256G SSD card for apps/programs/system, internal 500G SSD for data (music files). Current and updated Harrison MIXBUS version 32C 5.3.4 (rev 5.3-4-g2abd19f), which works like a charm. All old files and DAW functions work. I am running a Bluetooth keyboard and mouse, and the interface is a MOTU 16A via Thunderbolt, with the Mini driving both a Viewsonic 24" computer monitor and a Samsung 43" UHD 4K.

But…

My original Faderport (Classic), which worked fine via USB on the 2012 Mini running the same software (this version Mixbus and this version of Mojave), refuses to be recognized in the OSX Midi sceen, or by MIXBUS. Some buttons light up, but nothing functions. I've tried following various instructions on the blogs/support groups, and downloaded the 'recommended' files from Presonus. Nothing.

There are some comments out there about firmware upgrades that only work via a USB 2 device, not USB 3 (see below), but my installing various drivers and connecting the Faderport to other computers (USB 2 devices) for this alleged firmware upgrade has gotten me nowhere. Not sure it's even needed!

Presonus has been of little help, other than to indicate that Classic isn't supported anymore, and their software page for Classic names vintage 'update' software that can be downloaded (which I've done) but nothing names MIXBUS. Now I have a bunch of useless drivers clogging my computer...

Yes, I've toggled Preferences:Control Surfaces:PreSonus Faderport to no avail (as well as tried other controller options), and under 'Show Protocol Settings' for Faderport my 'Incoming MIDI on' dropdown only shows 'Disconnected,' or 'MOTU 16A LTC,' or 'mio,' a MIDI patch cable to my Allen & Heath Spectrum console w/ MIDI mute. My Outgoing MIDI on shows Disconnected,' or 'mio' as options. I assume this means it's not 'seeing' the controller. Have rebooted after changes to option selections, to no avail.

My Preferences:Sync:MIDI settings are all on. Inbound MMC device ID is 127, outbound is 0. I am not using the board's MIDI functions right now, or any keyboards or other MIDI devices, so these settings have not changed with the computer changeover. It all used to work fine with these settings. Disconnecting the 'mio' MIDI USB cable makes no difference. I'm out of troubleshooting options….

And looking at the support boards, this problem is not rare. But nobody seems to have a definitive answer, either. Am I screwed? So, my friends, how do I get the Faderport fully functional? Is this a USB 2 vs. USB 3 issue (2012 vs 2014 Mac mini)? Is there a MIDI setting I've got wrong (even though nothing changed, and it all used to work completely fine, as is, on the 2012 Mac)?

Thanks, in advance. Hope someone has an answer or a hack!

Mike Joseph, RabbitRunRecording, Midwest Audio Restoration Service (facebook.com/mars4tapes)

Please log in or register to answer this question.

...