Questions & Answers

Won't Connect - Blinking Blue Light on Q2626 with M1 Mac Mini on OSX 11.1

+2 votes
399 views
asked Dec 16, 2020 in Thunderbolt - Quantum by ericbryant1 (540 points) 1 flag

Mac Mini M1 new out of the box on OSX 11.1 and S1Pro v5.1, new Q2626, 0.8m StarTech TB3 40Gbit/s cable. Blinking blue light. Have uninstalled and reinstalled UC twice (Latest version 3.4.0.61835) with reboots between. Cannot get "Allow" to show up in Settings/Privacy/General. Can I add permission manually after-the-fact for the OSX TB driver or UC? Thanks!

6 Answers

+1 vote
answered Dec 17, 2020 by mukappa (370 points)
I have the same problem on a MacBook Pro M1 "Big Sur" - I've tried the deinstallation/reinstallation of UC many times and I simply do not get a prompt about permissions and there is no "Allow" button in System Preferences. Please, PLEASE help!
+1 vote
answered Dec 17, 2020 by mukappa (370 points)

Looks like there's a compatibility problem with the Apple Silicon M1: https://support.presonus.com/hc/en-us/articles/360051407452-Apple-Silicon-Computer-Compatibility

+2 votes
answered Jan 9 by sunilsatyamurti1 (240 points)
I am having the same problem on my MacBook Air. I was told by sweetwater.com guys that it would work with the new mac and hence I bought it. Not sure when it will work. Presonus, can you throw some light on when you ar going to make it work?
+1 vote
answered Feb 13 by caseyjohnson4 (160 points)
M1 MacBook Pro late 2020, interface not recognized in Logic Pro OR Ableton Live.

I downloaded the latest DRIVER from February, no avail.

The light on the unit is blinking blue, it shows a red light when I use my apple Thunberbolt3 cable which is even worse!

I SPECIFICALLY asked the rep at Zzounds if it was Thunderbolt3 compatible and he said yes. Presonus customer service phone support is closed (Saturday), Im not loving this whole process. Will be shipping back to Amazon ASAP and getting the UAD Apollo X6 or the Focusrite Audio Interface.
+1 vote
answered Feb 14 by ianwidgery (1,000 points)
Same here! New mac m1, new 2626. No support for M1 users... with the exception of a response from Presonus telling me the M1 update should be availble in 2 weeks - That was over 2 weeks ago. C'mon support your users.
+1 vote
answered Feb 14 by ericbryant1 (540 points)
Weeks? I've been waiting for months. December, to be precise.
I installed the Feb 9th update for UC and still no connection. Blue Blinker.
I'm using a certified 0.5m TB3 cable.
I bought my Q2626 in December to replace a failed Focusrite 18i20.
This week I'll take delivery of a new 3rd Gen 18i20.
PreSonus, this was not part of my studio's financial plan, FYI.
I must ask, how hard can this be? What's the hold-up?

Thanks,

Eric
...