Questions & Answers

My audiobox 1818 vsl stopped working completely when I did a firmware update. help!!

0 votes
1,489 views
asked Mar 15, 2020 in AudioBox VSL Series by iangreendale (150 points)
I recently bought an iMac Pro.  It runs the latest version of Catalina (10.15.3) Now when recording audio, there are lots of clicks and pops.  Also, the USB sync light flashes red/blue continually. I tried to reinstall the driver, but now only the universal control app exists on the website.  I downloaded it.  the only option it gave me was to update the firmware, so I did it.  Now the blinking light continues, but in addition, the Mac no longer recognizes the AudioBox 1818VSL in the sound part of the system preferences.  It also isn't listed as an available interface in logic.

Any help would be much appreciated

2 Answers

0 votes
answered Mar 16, 2020 by AlexTinsley (925,190 points)
 
Best answer
For situations like this you most definitely need to open a support ticket with the support team so they can do a deep dive to determine if it's software or if there's a hardware issue. Answers is not the place to do that.

Please take a moment to register your AudioBox 1818VSL in your https://my.presonus.com account.

Then open a support ticket by clicking the button that says "Create a Ticket"
0 votes
answered Jan 19, 2023 by PresonusAaron (620 points)

This happened to me to me after a firmware update, I submitted a ticket, and they told me it's been discontinued, and a solution that didn't work.  So what I did was uninstalled UC, then download the old UC 8.1 i think, then got it working again.  I then download the UC 3.2 ver I think, and did the update, and even updated the firmware and it still works.  So I'll leave it there, i'm afraid if I go up to high in versions I'll break it again.

...