Questions & Answers

Audiobox 1818 VSL stopped working

–1 vote
asked Mar 13, 2020 in AudioBox VSL Series by jimmygrant (170 points)
Not happy! My Audiobox 1818 suddenly stopped working. I have it plugged into a USB 2.0, everything was fine for the last 6 months, but then it stopped working all together. I think it's having a firmware issue, but now it wont sync up to any of my computers at home. I've tried three of them, installing new universal controller, but it's just red lighting, and doing the christmas tree light show...I've had nothing but problems with this crappy device since I've owned it, and it only gave me about 6 months hassle free. Yes my sound settings are 48,000, yes I have installed, uninstalled, reinstalled, turned off, waited the stupid 15 minutes...everything...This is the worse sound device ever made. Presonus should be ashamed. I have a backup 22vsl  which doesn't give me any problems...but the 1818 is ***** across the board. No one is happy with it. So many problems in so many forums. What can I do besides take a sledge hammer to it and NEVER purchase another product from presonus again!!! *****!!!

3 Answers

0 votes
answered Mar 13, 2020 by joegilder (13,630 points)
I had your same experience with a StudioLive mixer. I got angry and frustrated, only to realize that my firewire cable had gone bad. Did you try a different USB cable?
0 votes
answered Dec 24, 2020 by johnhajewski (140 points)
Same thing here, except I have used it for many years no problems... recently updated the drivers, which I immediately regretted because it removed the mixer software UI.. and effects... but i figured I would be ok with this universal control thing... then today I go to start recording and the device is not recognized by the pc. Changed cables, ports, reinstalled drivers, nothing... tried plugging it into a laptop- nothing... not even the little bloop sound... i have win7 on my main machine... this sucks. Now what?
0 votes
answered Jan 19, 2023 by PresonusAaron (620 points)
This happened to me to me after a firmware update, I submitted a ticket, and they told me it's been discontinued, and a solution that didn't work.  So what I did was uninstalled UC, then download the old UC 8.1 i think, then got it working again.  I then download the UC 3.2 ver I think, and did the update, and even updated the firmware and it still works.  So I'll leave it there, i'm afraid if I go up to high in versions I'll break it again.