Questions & Answers

auto scroll set to on: auto off, manual on. ' why not auto off, auto on?''

+6 votes
asked Mar 28, 2020 in Editing by johndecarteret (600 points)

Like many I have noticed that Auto Scroll has turned itself off in response to what the operator is doing as per design. No problem, but then you have first notice this has happened and then in various ways manually set auto scroll to ON again, unless you press stop and then it automatically resets itself.

As Auto Scroll turns itself off when the criteria is met to do so, could this not also work in reverse? 
The first criteria to turn itself OFF when required is that it must be ON, otherwise no action. If Auto Scroll has been selected and set to ON, it has to meet a set criteria to Turn Off and until that is met it remains On. So having met the criteria to Turn OFF, when that criteria is no longer met, can Auto Scroll not then Automatically Turn itself BACK ON. So when it no longer meets the criteria to turn OFF, it automatically turns Back to On and again waits for the criteria to be met to turn off again as and when required and when this is not met it's default is ON provided it was selected to begin with.

This would solve a lot of issues with auto scroll on this point and not just in editing, but in every situation that someone would want to do something in the timeline, anything that would cause it to turn off, would have it automatically turn back on after action is completed. Mixing, Mastering etc.

I mean when it's set to OFF and not selected, it doesn't look for the criteria to turn itself off. Surely this can work both ways. I hope I've explained it well enough or at least given enough information for users to see what I mean somewhere amongst that lot.



2 Answers

0 votes
answered Apr 10, 2020 by aka_busker (32,870 points)
Hi.  Not sure you are aware but pressing the [F] key at anytime switches autoscroll on and off.  No need for a macro complicating matters.  Its a toggle too.  
+1 vote
answered Oct 12, 2020 by robertgray3 (42,190 points)
It already automatically turns back on if you use any Transport command. I personally dislike this behavior but it already behaves very close to the way you requested.

if you don’t want to pause and play again, you can just hit the F key