Questions & Answers

how do I load BFD Eco as a VST instrument (the standalone player works and sounds fine) in Studio One 2 Professional?

0 votes
292 views
asked Sep 24, 2016 in Studio One 2 by joemartinaudio (150 points)
I am new to Macs and Studio One, having spent a very long time on Cubase on Windows, and having done practically nothing the last few years, except accumulate hardware and software, that I am integrating much later than I ever thought.

I have BFD Eco on DVD.  It's installed, and the standalone player works and sounds good.  I cant find it from within Studio One.  It doesn't show up as an instrument.  I have copied the BFD files into library>audio>plug-ins>VST on both my User folder as well as the Macintosh HD folder.

OS X El Capitan 10.11.6

Mac Mini (late 2012)

2.5 GHz Intel Core i5

8GB 1600 MHz DDR3

Intel Graphics 4000 1536 MB

Studio One 2 Professional (which seems legit when Im logged in to the PreSonus site, but I don't see the word "Professional" anywhere when I actually run the software.

So I just want to be able to have BFD Eco as an instrument track in Studio One 2 Professional.  I have a lot of experience with DAWs, but not this particular one, AND Im new to the OS as well.  And my software is legit, but barely used and a little bit old.

Also, I have an AudioBox 1818VSL, works like a champ! <3

1 Answer

0 votes
answered Oct 12, 2016 by connorguiberteau (18,240 points)
 
Best answer
1.  Open Studio One and go to Studio One>Preferences>Locations>VST Plugins and verify that you have the correct directory added to the list of folders that the program scans at startup.  You want to add the directory that you have your plug-ins installed to.  If you do not see the "VST Plug-ins" tab under the Locations tab, then you want to make sure that you have activated Studio One Professional or Producer or you have installed the VST, AU, and ReWire support add-on if you are running the "Artist" version of Studio One.  Press the "Reset Blacklist" button while you are in this window.

2.  Studio One will only load 64-bit plug-ins into the 64-bit version of Studio One.  The 32-bit version of Studio One will only load 32-bit plug-ins. If you need to run Studio One in 32-bit mode, simply ctrl-click (right-click) the Studio One icon in your Applications folder and go to "Get Info."  You can then check the box to run in 32-bit mode.  

3.   If you are still having a problem, try contacting the manufacturer of the plug-in for information about updates, compatibility issues with Studio One, or possible workarounds.
...