Questions & Answers

Mapping m-audio keystation 49 II

+1 vote
650 views
asked Feb 1, 2017 in Studio One 3 by olavbjnes (240 points)
I have tried several times mapping the transport and play, stop and rec button on the Keystation 49. i only get the volume and mod up.

5 Answers

0 votes
answered Feb 2, 2017 by Jamesrhone1 (198,310 points)
 
Best answer

Here are steps to assign your transport controls. 

1. Create a Control Surface for your Device.

2. MIDI Learn your transport buttons in the Mixer view External devices, and assign the desired transport controls. 

asked Feb 5, 2017 in Studio One 3 by olavbjnes (240 points) Mapping keystation 49 II
+1 vote
answered Feb 5, 2017 by olavbjnes (240 points)
i have tried that. The buttons dosent show up, The only thing that shows up is the modulation wheel and the volume. I cant rightclick on them. it just comes up copy text to clipboard. Do i have to download a driver or something? or maybe the buttons is broken.
–1 vote
answered Feb 2, 2018 by jaywelter (310 points)
There must be missing information from Jamesrhone1's answer. When I select my keystation 49 at Receive From port, Studio One tells me that port is already in use and bad behavior could result.  Another thread I looked at said to pick MidiIn2, which was there for me, but selecting it, putting into midi learn and pressing the buttons, nothing happens.
+2 votes
answered Feb 27, 2018 by gregsurr (190 points)
I found a way to get the transport buttons working! After pulling my hair out for an hour I found a thread on another forum that had a method that worked for me.

Go to your options>external devices>add

Click "Control Surface" at the top. This tells Studio one that what you're about to set up is a control surface and not a keyboard or instrument. (Your keys will still play notes just fine, don't worry)

Then go down the big list of preset devices to "Mackie">"Control"

This is the weird part. Set your "Receive From" to "MIDIIN2 Keystation 49" (Might say "MIDIIN3", "MIDIIN7", etc)

Then set your "Send To" to "Keystation 49" It won't say "MIDIIN", just "Keystation 49"

Click okay and pray to whatever god, deity, quantum entity, or cosmic force you believe in.

Post results?

For me this makes Play work normally,

Stop to stop playhead, and if pressed again return to start of timeline

Record to work normally

I am really hoping I didn't do anything weird that might make this work for me but not others.
0 votes
answered Mar 12, 2018 by markharris9 (210 points)

gregsurr  , your advice worked for me, i now have transport controls by doing what you said with the mackie control thanks!

...