Questions & Answers

Why does my StudioLive 32.3.2ai flip back and forth from meters to EQ.

+1 vote
317 views
asked Oct 29, 2015 in Ai Mixers by jefferyheid (180 points)
edited Oct 30, 2015 by jefferyheid

I have a month old StudioLive 32.4.2ai mixer.  When you press one of the "meter" buttons, it shows the signals in the meters for a split second, then flips back to the EQ FAT channel (?).  Sometimes it will randomly switch back and forth between both options, but it will settle on the EQ.  The input button stays lit the whole time.  Press it, the light turns off and stays on the EQ.

All systems have been updated to the current firmware and updates. 

Ignore the audio:  

7 Answers

–1 vote
answered Oct 29, 2015 by gadget69 (28,800 points)
The first thing your ALWAYS going to be asked is if everything is up to date with the latest drivers. You will be directed to your "My Presonus" account to download the latest firmware, and drivers and they are all in your account.

When the OS is updated, the drivers need to be updated as well. Even though your console is only a month old it doesn't mean that it is up to date. In this business with changes happening so frequently, you NEED to become very well versed with your account. See if that helps and let us know.

Best regards
+1 vote
answered Nov 28, 2015 by Rickcperry (160 points)
More of a question than an answer... Has this issue been fixed? Yes I have a new mixer and just updated the firmware and mine still does this.
0 votes
answered Jun 12, 2016 by ntfmedia (140 points)
Not an answer, but rather another question to see if this was answered and what the fix was as I'm experiencing this as well. Will be upgrading the firmware shortly, but according to the original question this did not appear to correct the issue.
0 votes
answered Jun 12, 2016 by jefferyheid (180 points)
Frankly. I feel that presonus needs to address this. For me. It was like an eq was stuck between "4 and 5" and it didn't like that. I had to watch for an eq to flip between two markers on a frequency. Once I spotted it and adjusted that eq frequency the problem went away completely.
0 votes
answered Jul 14, 2016 by kevinbelles (140 points)

same issue here.... the first complaint was almost 9 months ago...no response from Presonus?

I just purchased the board 2 weeks ago and immediately updated the FW and pretty much immediately noticed the issue.

 I guess I should consider doing a warranty return to see if this will force someone to look at the problem...hmmmm

0 votes
answered Jul 5, 2017 by twhartman (140 points)
edited Jul 5, 2017 by twhartman
Also not an answer, I am having the same problem on TWO brand new 32.4.2. AI Series Mixers.

Both have been upgraded to the very latest firmware (according to my PreSonus account) which does not fix the issue.



PreSonus, please comment if this is a known issue.

Thanks,

TW
0 votes
answered May 8, 2018 by edwardpopp (140 points)
I purchased a used 32.4.2ai that when it was in "input" or "output" meter mode it would all of a sudden flip to the EQ on all the meters and then after a few seconds would flip back.
I restored it to the defaults a few times.. then i re installed the firmware.. then iI did a firmware recovery-factory reset 3 times and it fixed the problem..
I have it turned on and set up in my living room so i can watch it and it hasn't switched to EQ mode in over 7 hours.. crossing my fingers tho.. hope this might help someone..
here is a link to how to do the recovery.....
https://support.presonus.com/hc/en-us/articles/210047893-StudioLive-AI-Mixer-Firmware-Recovery-Factory-Reset
...