Questions & Answers

Making Studio One 3 Professional recognize EZ Drummer 2 / Superior Drummer

+2 votes
asked Dec 2, 2017 in Studio One 3 by garytarplee1 (390 points)
Hello all,

I searched for the answer to this but everything I have looked at doesnt address my issue. I have Studio One 3 Professional. I have Superior Drummer 3, EZ Mix and Helix Naive. Upon start up, my helix native shows up under "line 6". Toontrack shows up in my VST plug ins, but the folders are empty and I cannot access any of my EZ Mix or Superior Drummer files or audio sounds. I am sure that I must be doing wrong but I cannot figure it out. I have gone to "options", "locations" "VSTplug ins" and ToonTrack does not show up under an accessible folder.

I dont know what else to do! I have been fighting with this for hours now.

Second questions

When I want to add my drums, do I do it under "instrument track"?

8 Answers

0 votes
answered Dec 3, 2017 by karstenvogt (3,430 points)
selected Jun 28, 2019 by nickmaggio
Best answer
Please check:
- did you install Studio One Prof. 64bit? If so did you install your plugins as 64bit version?
- Did you set the path to the 64bit plugins correctly in your Studio One preferences?
- Try resetting the VST-Plugin blacklist (see preferences)

If they show up in your instrument browser, just drag and drop the plugin into the arranger window. A new track will be created automatically.
0 votes
answered Dec 2, 2017 by joeypinter-bilek (1,020 points)
hey, this, unfortunately, is not an answer. however, i have the same problem (sort of) studio one 3.5 sees SD3 but i haven't a clue how to get it to work like i did in sonar platinum. i haven't even tried to see if EZmix is working. i'm just trying to get something going. if you get any ideas form anyone could you please send them my way.


0 votes
answered Dec 2, 2017 by robertedwards6 (140 points)
I admit I do not own PreSonus to try this on (investigating it today), but I can tell you I've run into this problem on several other DAW's because I was trying to get it to go on a mono track. Absolutely MUST be on a stereo track. Spent 6 hours trying to figure that out on Reaper one day...

Hope that helps.
0 votes
answered Dec 4, 2017 by garytarplee1 (390 points)
Its still not recognizing it. I have made sure all plug ins are 64 bit. I have added the plug in, saved, closed the program and I get a ToonTrack (EZ Mix, Superior Drummer 3) folder on the left side of the screen under Files, but the folders are empty. I have uninstalled every program (ToonTrack, Presonus, Sonar Platinum, Helix Native) reinstalled every program and nothing. For giggles, I uninstalled PreSonus and reinstalled Platinum and ToonTrack and Helix Native show up.

Everything is working as a stand alone. I can open EZ Mix and fully operate on its own. Same with Superior Drummer and Helix Native. I have watched numerous videos and everything I have tried, I get the same result. A toontrack file with an empty folder.


Sweetwater tried to remotely fix and they cannot do it either. They say they have never seen this before.

So, this is where I am at with this situation as of 12/4/2017.
+1 vote
answered Dec 6, 2017 by garytarplee1 (390 points)
This problem has been solved. Apparently PreSonus wasn't seeing the "common files" folder in the C drive of my computer. Once we realized  that was the issue, we pulled them into PreSonus and everything shows up now.

Problem solved and my PreSonus Studio One 3 Professional is now completely up and running.
0 votes
answered Mar 2, 2018 by jesserlucero (140 points)
So how did you get it to recognize the folder and fix the situation. I’m having the same issue but with Power Drummer.
+3 votes
answered Apr 9, 2019 by davidaddis1 (220 points)
I realise I'm a bit late to the party, but in response to jesserlucero, I had to add to open Studio One, and (before opening a song), go to "Studio One" in the menu, "Options", the "Locations" tab and add "C:\Program Files\Common Files\VST2" to get EZDrummer to work.

This is on Windows 10, 64-bit Studio One v3, 64-bit EZDrummer v2, and I have the VST add-on for S1.
0 votes
answered Jul 13, 2021 by stuartjackson1 (140 points)
I had this same problem and for the first week after purchasing SD 3 I couldn't get it to show up in Studio one. Finally figured it out and wanted to share in case any one had the same issue.

You have to make sure that under Options -> Locations, that the folder that has superior drummer (or any instrument plug-in) is under VST's, and external instrument.

If you did that and it still isn't working, make sure the file that is labeled Application Extension (.dll) is in the same folder as superior drummer where ever you saved it. For some reason the dll file wasn't in the same folder and once I put that under the folder that studio one was looking it worked like a charm.