Questions & Answers

External Synthesizer Midi to Audio Recording offset and jittering Problem

+4 votes
asked Feb 25, 2018 in Studio One 3 by yourecord (850 points)

Hello,i have a Problem with my external Synthesizers.
I have controlled them via my Motu 4x4 on a USB 2.0 Port (also tried different USB Ports as well as USB 3.0)
When i send Miditracks out to the Synth´s i have Problems to record the Synthesizers wich contain following Problems:

1. The recorded Material has always a offset (like in the picture)

Therefore i tried to set the general Midi offset in Options, but this wont affect the recorded Material at all, it always stays in the same offset like in the Picture above.
When i try to set the offset individual on each Miditrack, i have heavy Midinote hangings.
Also i brought it so far that it would record the first note on the Grid like supposed in the Miditrack and then after that the second note comes offset.

2. When i send Midi Sync and Midi Start on each instrument, my external Synths are having heavy Problems to get a accurate Midiclock.
This affects synced Delays wich glitch/jitter heavy and LFO´s that are synced to the DAW.

3. I have tried to controll the external Synths with USB Midi only on different USB Ports as well, and there is the same Problem, so i assume to exclude that the problem is the 4x4 Motu Midiinterface.

4. I have tested the Problem on both of my Studio PC´s wich are:
- AMD based (selected high end parts only) on a 19" Case PC on Windows 10
- HP EliteBook 8570w Intel Based, wich is also a very good machine (even better than the AMD), also Windows 10.
The HP Elitebook has PCM CIA FW Card from Texas Instruments wich was also tested with the Studio Live 16.4.2 Board.

I use Zero Latency Monitoring with my Studiolive 16.4.2 with a Texas Instruments Firewirecard.
My Settings are low latency in the  Universal Control Panel, i also tried normal mode and safe mode, wich makes no big difference.
I have mostly a buffer Size between 32 and 128, but mostly 64, wich runs very fine is i work "in the box" only, i can open lot´s of plug ins (also 3rd party) and still have a good performance.

I Have tried to record my external Synths in other ways as well, wich no Zero Latency Monitoring, or no Dropout Protection, wich makes no difference on recording my external Synths.
Also if i record a Synthesizer by playing live with my hands (without sending Midinotes), everything is on the spot as good as i play live, so there are no Problems, but still the glitches/jittering exists for synced Parameters of the Synthesizers.

I have following Synths connected:
Arturia Minibrute
Roland System 1
Novation Circuit
Novation Mininova
Korg Volca Bass

Both Machines have the latest Version of Studio One V3
Also i tried not to work with any of my templates, but only make a new empty song with only one external Synth with one Miditrack and one Audiotrack to recieve the Audio, and the results are the same.
No other Plug ins, Busses or FX Returns where used at this time.

PS: Hopefully i have adressed my problem as good as possible.
I have to complete, if there are some missunderstandings, please tell me, i have aspergers autism, and often have problems to express myself in the right way, or describe the problem understandable, wich often results in problems and makes things more complicated as they already are.
So please let me know, if something is unclear in this case,because i Adressed this Problem already in the Presonus Facebook Group called "Presonus Studio One" by Nick Critchley, he and many many others helped me as good as possible.
Also he told me he already contacted the Tech support for me, and to tell me to adress my problem directly.

Thank you in advance, best greetings from Germany, Frowin von Boyen

3 Answers

+2 votes
answered Feb 26, 2018 by danielbayer (2,960 points)
I have similar issues here. After a bit of research I came to the conclusion that the main problem is MIDI jitter. Even if I manage to adjust the (negative) track delay of the MIDI track, so that the first recorded audio event is on spot, doesn't mean that the following events will be too. This means that the timing is not stable and also depends on how many MIDI messages are sent in a given moment. The same behaviour occurs with Ableton Live, so this is nothing S1 specific and is (as I understand it) caused by the low priority of MIDI on a computer.

I was told to get an E-RM Multiclock for a more precise timing but didn't do it yet because of the high price of the unit. My workaround is to quantize the audio afterwards, especially drums recorded from my drum synthesizer. This is not optimal, but it works for me and until I'm willing to shell out 550€ for the Multiclock.
0 votes
answered Mar 29, 2018 by Jemusic (400 points)
edited Mar 29, 2018 by Jemusic

I have been doing some tests with my system and can report some results. Firstly I have an all external midi system with 6 hardware synths attached and 3 computers all being virtual instruments.

The results of a test like this can vary. I am using all the 5 pin DIN Midi IN/OUT connections on all my synths, not USB. I have a separate PCI based card that provide 4 USB outputs. I am driving the Midex 8 Steinberg interface from this card. This is the only thing on this buss.

When quantising midi note start times to the grid I can feed this out to all my synths and record the resultant audio wave form back in. Selecting the fastest type of rise time transient sounds are the best for seeing when they actually start producing sounds occurs.

The time between the midi note on and the start of any audio sound varies for all 6 of my synths.  As fast as 3 mS for my Kawai K5000W.  Others at 4 to 5 mS and even as high as 9 mS in some cases. This does depend on how much dead air exists before a sample starts too in many case and there is often dead air present. Making this test a little invalid.

The Kawai in my case could send an alignment tone upon receiving a note on and this was pretty fast. This time between a midi note on and the actual start of any hardware synth audio is variable to say the least. For every patch it needs to be tested and taken into account in the final mix.

Any delays are very consistent and I get no jitter as such.

In the end of the day what you really have to do is once all external midi sounds are converted to audio, one should listen to those parts in relation to the metronome. And fine tune the track offset e.g. negative times to bring the sound back into the groove. Many sounds don't sound like they are hitting right on the beat because there may be a short rise time before a transient sound actually climaxes. e.g. 3 or 4 mS. These tracks need to be pulled back that amount to get the loud parts of a transient hitting right on the beat.  

Another option is fine tuning the placement of audio events visually using the transients as a reference. It has a similar effect to advancing audio tracks.

Your ears are the final judge here.

I could put forward the notion that the system actually works fine.

So far what we have been looking at here is to do with sending quantised midi note on events on the grid. i.e. midi tracks playing back to external hardware synths.  Another situation comes into play when you play live from a controller and into a Studio One midi track plus sending that midi track out to an external hardware synth and it generating a sound at the same time which is also recorded simultaneously onto a audio track.  NOTE Before you do this ensure Input Quantise is OFF. This can catch you out and create some strange results.

Then you can compare the midi note start times to the audio. While recording I am getting instant timing from the synth from my keyboard.

On playback I can get the recorded audio to be consistently between 1mS and under from the start of the midi note on event. (usually later but sometime the audio appears early by a fraction of a mS) Note no playing to click here or any form of quantisation afterwards. I have to set my Midi Record Offset vale to 8 mS in order to achieve this in terms of the recorded audio and midi notes lining up.  No or very low jitter though, overall extremely consistent for me in this mode. (Note this Record Offset setting would vary according to the synth itself and the patch)

Even if you trigger the hardware synth again on playback and listen to the previously recorded audio as well as the midi triggered audio, I am hearing only the tiniest of flams taking place. Timing is literally right on top of each other.

If you were going to now quantise the midi parts (because you did do this to a metronome) then those note start times would all land on the grid. You would have to do something similar to the audio e.g. audio bend and quantise in order to get those two things to agree again. Then fine tune the audio by eye again for a final check.

0 votes
answered Mar 13, 2019 by stefanek1 (160 points)
edited Mar 13, 2019 by stefanek1
Same problem here using a ESI Juli@ internal soundcard sending midi to any hardware. The first note / beat is always at a random position, sometimes triggered before the audio recording started and sometimes late.

My usecase is recording hardware, and overdubbing.
It's not possible because of the start clock inconcistency.

Tested with Ableton and FL Studio, and the recording ALWAYS starts spot on, no jitter what so ever. And no lag.

Will probably be switching to Ableton since this behaviour is completely unacceptable. Even fruity loops is better.