Questions & Answers

Why Am I Having Issues With The Studio One 4 Plug-In Scanner

+14 votes
asked May 24, 2018 in Studio One 4 by lawrencefarr (221,410 points)
Studio One 4 appears to hang on scanning plugins.   Can you tell me why that may be happening?

13 Answers

–4 votes
answered May 24, 2018 by lawrencefarr (221,410 points)
Best answer

Thanks for all of your patience. Below you will find a link to a knowledge base article that addresses this issue.

Best Regards,

+2 votes
answered Jun 1, 2018 by robertfass (180 points)
edited Jun 1, 2018 by robertfass
Thank you for the response.

I first tried deleting the user settings folders in C:\Users\UserName\AppData\Roaming\PreSonus\Studio One 4\x64. The Studio 1 uninstaller was not removing these directories. Once removed, Studio 1 Version 4 went through the new setup scripts and everything worked fine. It started normally and I could get create new songs.  After downloading all the content plugins to the default locations and restarting,  it hung up again scanning for plugins. This did not happen in Version 3.5. It would load all plugins immediately. I  turned off firewall and antivirus and still hangs!
+1 vote
answered Jun 6, 2018 by ansolas (4,250 points)
I have the Studio One 4 Demo, and it hang here as well. (macOS)
+1 vote
answered Jun 6, 2018 by lutzvogelsang (1,380 points)
I am running SO4 Demo on Windows 7 and have the same issue.
I created a support ticket and have been told to wait for an update.
+1 vote
answered Jun 20, 2018 by uldericom (180 points)
Same issue here as well....win7/64

Runtime error


- CRT not initialized

Impossible to load all vsts, demo unuseful
+5 votes
answered Jul 17, 2018 by chrisbotsivalis (240 points)
I had the same problem with Studio One 4(windows 7,64bit).THE ONLY SOLUTION for me was to roll back my graphics driver.I have Nvidia Geforce GT730,rolled back to driver version 388 and problem was solved.Any driver above 388 will cause a problem.Hope this helps!!!
+3 votes
answered Jul 23, 2018 by ionian (2,110 points)

I just bought the SO4 upgrade and had this exact problem.  chrisbotsivalis was correct.  I rolled back my Nvidia driver to the previous version and SO4 stopped hanging at the scanning plug ins page.

+1 vote
answered Jul 29, 2018 by dstdean (200 points)

I experienced the same hanging problem.  It WAS NOT the anti-virus as Presonus Support suggested.  I was the Nvidia driver problem that  chrisbotsivalis  and  ionian  identified.     I rolled back my  Nvidia driver to 388.71 and problem was solved.  Thanks guys!!

+2 votes
answered Jul 29, 2018 by staffordwilson (370 points)

Same problem here. Win 7 64bit, Nvidia GTX760, running Studio One 4 Demo - hanging on scanning plugins message at start-up. Reverted to Nvidia driver version 388.71 - not hanging anymore.

Hope you guys can fix this as I don't want to have to stop updating my graphics drivers!

+2 votes
answered Oct 6, 2018 by alejandrosuazo (1,000 points)
Same all problems described here with V4, v2.6.5 run flawless. In windows 7 64 rollback Nvidia drivers, but in Windows 10 if disconnect to internet or use firewall, all plugins with internet validation crash in SO4, not in Cubase 9.5 or Live! or Reason 10

This clearly has a very very BIG BUG with the SO v4. Please presonus, come on guys! STOP making simple tools and FIX IT the big problem with your **** SO V4!
0 votes
answered May 28, 2019 by joshuarodriguez15 (140 points)
I had this problem. I recently started using  S1 and never had an issue like this before today. I typically have my PC disconnected from all networks while running a project. I recently reorganized my plug ins and had reset the black list and re scanned on startup. I got hung up on waiting for plugins.  I tried reconnecting my PC to the internet, and restarted S1. Presto. I guess because I'm running some additional content that needed to access the internet. But that's lame. A lot of producers try not to be on the internet when running a project to save resources, and to stay focused on work. But if the video card thing doesnt work try making sure S1 can connect to the internet.
0 votes
answered Jun 11, 2019 by erikaanonsen (2,350 points)
I, too, had this problem. I had to go online for it to function again. (June 2019)
0 votes
answered Jul 13, 2019 by mciv (1,070 points)

4.5 still has this plugin scanner issue. I have NVidia Geforce GT 740 and Windows 7 Service Pack 1. Separate pluginscanner.exe which started all problems in Windows 7 doesn't work even with all gpu drivers uninstalled (tried in safe mode too to be sure - used ). Still what a music program with simple gui vst detection has to do with gfx drivers is beyond me (I make 3D graphics too). As a workaround I tried to copy "c:\Users\User\AppData\Roaming\PreSonus\Studio One 3\x64\Plugins-en.settings" and "c:\Users\User\AppData\Roaming\PreSonus\Studio One 3\x64\Vstplugins.settings" into Studio One 4 directory equivalents but it doesn't work. Here is excerpt from "c:\Users\User\AppData\Roaming\PreSonus\Studio One 4\x64\PlugInScanner.log" . What is "Async scan call timed out. Server process crashed"?

2019/07/13 16:36:42.016 [Info]: UI Status: Scanning 1 of 120: 3rd_Bass
2019/07/13 16:36:42.017 [Info]: Scan next file in scan process: 3rd_Bass
2019/07/13 16:36:49.639 [Error]: Async scan call timed out. Server process crashed
2019/07/13 16:36:49.639 [Info]: UI Status: Failed to scan 3rd_Bass
2019/07/13 16:36:49.640 [Warning]: Crash while scanning 3rd_Bass in a new process!
2019/07/13 16:36:49.640 [Info]: UI Status: Waiting for plug-in scan process...
2019/07/13 16:36:49.730 [Info]: UI Status: Scanning 2 of 120: 7amp-flyingecho-1
2019/07/13 16:36:49.740 [Info]: Scan next file in scan process: 7amp-flyingecho-1
2019/07/13 16:36:57.313 [Error]: Async scan call timed out. Server process crashed
2019/07/13 16:36:57.313 [Info]: UI Status: Failed to scan 7amp-flyingecho-1

... and it goes on and on with all other plugins