Questions & Answers

Cannot update AUDIOBOX USB 96 Firmware v1.14

+34 votes
1,617 views
asked Sep 13 in AudioBox USB by lonelypoe (370 points)
Hello all, I've just updated Universal Control to version 2.9.0 & received a notification to update the firmware on my Audiobox USB 96 from v1.10 to v1.14.

However, when I run the update it says my device cannot be found. I've tried restarting my PC, reinstalling Universal Control but nothing seems to work. I am now unable to use my audio interface unless I perform the firmware update.

Any assistance would be much appreciated.

Kind regards, Daniel.

3 Answers

+4 votes
answered Sep 18 by lonelypoe (370 points)
reshown Sep 24 by AlexTinsley
Hi all, just an update for anyone else who may be experiencing issues with the latest Universal Control. After raising a ticket & speaking with a couple of support guys, I was advised to go back to Universal Control version 2.8 & to ignore any update requests.

My interface works on the older version, so I assume there is an issue with the latest version of UC - therefore anyone experiencing issues, roll back to the previous version & await the next update maybe.

Kind regards, Daniel.
0 votes
answered Sep 24 by piotrmitka (140 points)
How am I even supposed back to Universal Control version 2.8? Do you have some link for this? I have same issue, can't update firmware from 1.12 to 1.14, seems like Universal Control "disconnect" my device and then try to update it. At the end I have same problem - my device cannot be found. Nothing helps, also connecting to other USB port.
commented Sep 24 by AlexTinsley (731,220 points)
You can go back to an older version of Universal Control by going to the download page and there is a link to "show/hide all versions of software downloads.....(for your Operating System)".
0 votes
answered Sep 24 by AlexTinsley (731,220 points)
 
Best answer
We encountered a problem with some AudioBox 96 units not updating correctly.

Not to worry, nothing will happen to the AudioBox 96, when the update fails it will revert back to it's base image of 1.10 and hot plugging it will take it back to either 1.10 or 1.12 depending on which firmware you last had installed.

To resolve this problem, uninstall UC 2.9 using the Programs and Features section of your control panel, then download and reinstall UC 2.8.

We've have since removed UC 2.9 from the downloads area and are working on an update to resolve this issue.

We apologize for the inconvenience.
...