Questions & Answers

How to best avoid recording dropouts?

0 votes
44 views
asked Jul 4 in Recording by erikhusler (3,680 points)
edited Jul 4 by erikhusler
The subject has been touched upon. But i think it needs to be further emphasized:

When tracking, especially audio, the most important thing, point blank, is to NOT get recording dropouts. This needs to be the highest - or only - priority when tracking. It means the pace/ rhythm must take priority over any sound dropouts.

My audio recordings (now jazz, mostly one track at a time) are being compromised. I try use Izotope's RX suite afterwards, but in a 3-4 minute mono track there is a ridiculous amount of dropouts. It seems a high buffer setting's inevitably linked to high VI dropout protection? If so, is it really necessary? Doesn't high buffers help other VST's perform better too?

Until the day Presonus manages to fix this, how do you guys handle/ work around it? Besides disabling plugins and bouncing. Turning buffer/ dropout protection down low? How low?

2 Answers

0 votes
answered Aug 4 by yuweixu (720 points)

First of all, you need a powerful processor. The best solution is to upgrade your gears.

Workarounds: Leave the ASIO buffer size under 512 to ensure your armed track won't have a ton of delay. Then, set the dropout protection to Maximum. This will let S1 to increase the buffer size of unarmed track and move them forward to compensate the buffer size difference so you can't hear the difference but you have more buffer size to get the unarmed tracks processed. Although this will add a small lag when you start playback each time.

0 votes
answered Aug 26 by erikhusler (3,680 points)
Thanks for your answer xuweixu.
My setup is a MacBook Pro mid-2014, OSX 10.12.6, 16 GB RAM, an external raided 4TB SSD for samples, a 1TB SSD for recording, all disks working optimally according to DiskWarrior. I've been able to run entire sampled orchestral setups with effects without glitches on S1 v.3, and AFAIK i get no glitches when recording in the latest Logic or Pro Tools 11 HD.

The recording dropout issue is something that's happened lately, on v.4.x. It could well be related to the introduction of the low latency recording mode - that's great for VI's. But given my setup I think there should be a way to minimize dropout protection (which intermittently stops to buffer, causing the tempo/ recording disruptions) in favour of keeping the tempo/ recording going. Any suggestions?

I think dropout protection, by default, should be disabled as soon as you record. But before that's implemented any suggestions are more than welcome. Thanks!
...