Questions & Answers

Faderport 8 - Firmware update 2.02 to 3.21 - UC v3.1. fails

0 votes
265 views
asked Aug 10 in FaderPort 8 by wlinz (200 points)
Hi,

I'm having some problems at the moment with my Faderports (Classic & FP8).
Universal Control v3.1.0.53214 for Windows, OS is Windows 10, Studio One 4.5.2.

Presonus tells me 'A firmware update is currently required for full functionality'

UC tells me to Upgrade 2.02 to Version 3.21 on my Faderport 8.
Nothing besides UC is runiing on the freshly bootet PC.
When I start the Update, UC works around 4 minutes 'updating' and then tells me the update was successful.

While the update is running FP8 shows 'Please Wait 0%' and stays at 0% the whole time.
When UC tells me it's finished, FP8 tells me 'Update failed - Please Power cycle'.

Does anyone have in idea how to fix that problem?

Walter

5 Answers

+1 vote
answered Aug 10 by shawnlutz (670 points)
selected Sep 3 by nickmaggio
 
Best answer
Does the Faderport 8 show up in the UC along with your audio interface? Is it possible the firmware has already been upgraded? This confused me a bit when I first upgraded Firmware. When you go to you mypresonus page products, faderport 8 it still has the note about Firmware upgrade required. Check firmware on the faderport to see. Power down the unit, hold down the ch 1 and 2 select buttons at the same time and power up. Go to Set up and it will indicate what firmware its running on. If it reads 3.21 from June 25, 2019. If its not try setting the unit back to factory defaults from the setup as I described above and then starting the firmware upgrade again.

I had to do the go back to Factory Default firmware process on a fader port I bought pre-owned (was damaged in shipping) as it hiccuped on my first attempt. I was able to upgrade it to current version but had to return the unit. I had no problem on the replacement unit.

Good luck!
0 votes
answered Aug 12 by Raffael Schmalzl (140 points)
Same problem here. For the second try I changed the USB Port. Same problem.

After the factory reset faderport says Version 1.01. Another try to update, nothing has changed
0 votes
answered Aug 12 by wlinz (200 points)
edited Aug 12 by wlinz

@shawnlutz: 

The FP8 already had 2.02 Firmware on it.
I updated it on the same machine (my Studio One Workstation) from 1.01 -> 2.02 last year without any problem, UC was 2.1 then I think.

After the failed attempts it was not upgraded, still had 2.02 even after several failed but according to the UC seemingly successful updates.

Same results after reset to FW 1.0.1 via setup.

Finally I could solve the problem :

- installed Universal Control v3.1.0.53214 on another PC, that didn't have anything Presonus on it.
The machine is nearly identical to the above one (both Lenovo E31 XEON 1230v2 / 1240v2 workstations)

- factory reset of the FP8 to FW 1.0.1 via setup (ch1 + 2 on power on)
- FP8 connected to of the front USB 2.0 ports of the machine -> update failed  (I think it's because the front bezel is in fact a USB Hub)
- FP8 connected to one of the mainboard (backside) USB 2.0 ports -> update was successful

As mentioned above I couldn't update my Faderport Classic either.

On the new machine it worked too. Same procedure

- factory reset by unplugging USB, holding down 'rewind' - 'stop' - 'record' buttons at the same time, plug in USB and wait 5 seconds, then powercycle again by unplug / plug in USB
- make sure to use a direct USB 2.0 port on the mainboard and the update succeeded.

On my Studio One workstation FP8 & FP Classic were always connected to direct USB 2.0 ports.
The problem seems to have to do with different older UC versions and the new UC 3.xx on the same machine.
I'm using different interfaces with the same machine, Firestudio 26x26 wth UC 1.2.2715, Firestudio Tube & StudioLive 16-4-2 with their UC 1.7.6, UC 3.1 for the FPs  and some other hardware drivers.

Maybe the 3.1 doesn't go along with one of the others for firmware updates. Everything else works great.

Thank You for Your interest and support.

@Raffael Schmalzl: maybe this helps a little to solve Your problem too. Good luck!

Walter

0 votes
answered Sep 5 by johndekker (330 points)
I had a similar problem with my faderport16. After the upgrade to Studio 4.53 my faderport was acting like a generic controller. I saw that it needed an update from 3.1 to 3.2. I updated the UC and then tried to update the faderport. I would get a message that the faderport had updated successfully but the faderport flashed red and said update failed. Also during the process, the percentage never changed.  I did a factory default reset to version 2.0 and still nothing. Then I tried your method. I took my little laptop that has no presonus software in it and loaded up the new UC.  I plugged in the faderport and it recognized it as 2.0 and needing an update. I ran it and voila! it works like a charm and now I have all my functionality back with the updated Studio 4.53. Thanks for the advice. All Presonus could do was ask for my NFO file.
0 votes
answered Sep 14 by artjohnson (290 points)
I was able to "force" the Faderport 8 to work with my system! Solved? Sorta...

This is long-ish. Apply patience...now.

Attempting something I came across here, rather than continuing to pull my hair out and curse, incurring failure after failure when attempting to update firmware by simply connecting the Faderport to my computer via a USB cable (including factory resetting it back from firmware vrsn 2.02 to 1.01), rather, I installed the Universal Control app onto a dying HP Pavilion dvp6 laptop it was my intention to recycle, connected the Faderport 8, clicked the "Update Firmware" button, and it updated first go without a hitch! It is assumed that the USB port on the aged laptop was USB 2.0.

To be VERY clear, even though I was able to update the firmware, when reconnected to my target system, with four USB 3.0 slots, the Faderport 8 only functioned intermittently, as though the USB connection was being continually broken and/or reset. So, as was also described (sorta) in this community, I discovered that if I inserted an ancient, off-brand, non-powered USB hub (assumed to be USB 2.0 as it was designed for use with Windows 2000 (!). I had forgotten that I still had this thing and had never once used it), when I inserted this legacy hardware in line between the desktop and the Faderport 8, the Faderport worked perfectly; just as advertised. The assumption here is that my USB 3.0 ports are not "falling back" to 2.0 as they should. My guess, of course. Too bad I didn't think of this when updating the firmware. Won't go back and try it now, right?

Anyway, the jury is still out as I was prompted by Nick at Presonus Tech Support to supply a system info file for their review. Hence, this tale may find a sequel. Further, I won't mark this issue solved until I can remove the old USB hub from my setup and run it as one might assume is intended.

In the interim, to save those few poor saps out there like me (and perhaps some annoyance to Presonus tech support), Presonus might add a "catch line" of code to the UC app that lays out quite plainly for the user in a text file or whatever, when a USB mis-match occurs. Just having the newly unboxed unit flashing and crying foul when there is a simple mis-match is totally disheartening. Some less tenacious folk might just bail on the product-line rather than work it out for themselves. Better yet, Presonus might seek to catch this issue in software and run a sub-routine as a software workaround. My take, of course.

Good luck!
...