Questions & Answers

How can I register my old Firebox purchased in 2007 please? I need to download Studio One or Cubase to use it.

0 votes
288 views
asked Mar 6 in Legacy Interfaces by maevamantione (150 points)
I don't know the exact date of purchase because it was a gift, but I know it was in 2007. I never used it, it is my first time. I downloaded Firbox Control and Fireboc Mixer, but I need Studio One or Cubase (I am usine iOS Mojave). Please, how can I register my product?

1 Answer

0 votes
answered Mar 11 by AlexTinsley (902,880 points)
 
Best answer
We really appreciate that you want to use the FireBox, however the last supported OS for the FireBox was Mac OS X 10.7.5. You won't be able to install it on Mojave. You'd have to go back to an older Mac running 10.7.5 to use it.

We would strongly recommend updating to a newer solution such as a Studio Series interface.

We can register your product for you, just log a support request through your https://my.presonus.com account and click where it says "Create a Ticket".
...