Questions & Answers

Missing Devices??

0 votes
asked Apr 13, 2021 in Studio One 5 by jacobpeterson6 (120 points)

Saved my song before quitting last night, now when i go to open it I get Missing Devices error. The plugins are still installed in the same place they were yesterday. I tried reinstalling, restarting, resetting my locations in options, removing the midi device and adding it again. I don't see anything online that has a fix for this. Please help. Thanks. 

1 Answer

0 votes
answered Feb 10, 2022 by nickhennessy (550 points)
edited Feb 10, 2022 by nickhennessy

Edit: first of all I should probably clarify I'm running an earlier version of Studio One, so please bear that in mind before proceeding.

I hope this isn't still a problem for the OP after nearly a year, but I had the same problem, and in case anyone else runs into it, here's what worked for me:

First of all, make sure you're cognizant of all your VST locations, as you'll need to find and re-instantiate them in Options>Locations>VST Plug-Ins once you're done.


1. Click 'Help'

2. Click 'Open Settings Folder'

3. Although this step shouldn't really be necessary, just to make yourself feel better copy the file 'Vstplugins.settings' to an alternative location.

4. Shut down Studio One.

5. Delete the file. 

Now, when you next run Studio One the settings file will be recreated - with any luck, minus whatever machine-logical mental block it is that's persistently causing this issue in the first place. Remember that before you fire up any individual song, you'll want to go in Locations as described above and add all your VSTs back in one by one. If you're anything like me this won't be a problem as their identity will be seared into your brain by the experience of having to install them in the first place. Anyway, best of luck...