Questions & Answers

Failed to connect to the server. Please check your internet connection and try again.

0 votes
632 views
asked Feb 27, 2022 in Studio One 4 by pawerusak (320 points)
edited Mar 2, 2022 by pawerusak

I bought a new SSD, uploaded Windows 7 pro 64, did all possible updates. I downloaded Studio One 4 Artist, installed and started product activation. I will add that I am upgrading from Artist to Pro. I entered the serial numbers, clicked on the Activate button and a prompt popped up: "Failed to connect to the server. Please check your internet connection and try again."
I tried probably all combinations, tried activating Artist first, then Pro alone, generated files for offline activation and nothing. I even checked the "host" file... I felt like some kind of software pirate :/ The Firewall thing is out because I don't use any, even the one from W7.
There is another combination that I haven't fully tried. I'll explain why not fully in a moment.
I left the previous installation on the old drive, just in case. On the Presonus page next to the product I noticed that in the Manage Activations tab the name of my previous computer is assigned. And here's a clarification, I changed the name in the fresh installation to the one in MA, which also did nothing.
I'll add that installing Studio One from the old disk works fine.
How do you think, the reason for this error can be an entry in MA?
If I remove it from MA will activation go forward? Any of you colleagues had such a problem? 
Edit:
I tried it and removed the MA entry, unfortunately but now I can't log into Studio One on the old system either. What is the issue here? :(


EDIT: 02/03/2022
I still can't log in, even on an old system and an old drive. :( Not to mention activating Studio One 4 Pro on the new drive.
Is this server hosted by the Russians? :D


 Please help, regards Nerg.

4 Answers

0 votes
answered Dec 26, 2022 by bryanmiller5 (290 points)
Please let us know if you find the answer.  I have been fighting this for almost a year now.   No fun at all.
0 votes
answered Dec 27, 2022 by martinchico (420 points)
edited Dec 27, 2022 by martinchico
I have the same problem. I have tried even connecting through my android phone connection to avoid my IP address and there is no way. I can't log in from the Universal Control application either, I keep getting the same error "Failed to connect to server. Please check your internet connection and try again". It seems as if they are redirecting the connection to another server or ┬┐maybe it is a user ban by Presonus?
0 votes
answered Dec 27, 2022 by martinchico (420 points)
It was a bad idea to think that I have been banned by Presonus. Surely the problem is for another reason
0 votes
answered Jan 2 by martinchico (420 points)
I solved it thanks to the presonus support team.To solve the problem you have to enable in the windows registry support for TLS 1.2 as default secure protocols in WinHTTP.
...