Questions & Answers

How to unbrick my VSL1818

0 votes
asked Nov 9, 2022 in AudioBox VSL Series by matthewsugden (120 points)
recategorized Nov 9, 2022 by matthewsugden
So I foolishly updated the Universal Control software yesterday which prompted a Firmware update on my now aging VSL1818, which has made the unit undetectable in windows. Basically seems to have bricked the device.

I've tried rolling back Universal Control all the way back to 1.3, tried removing all traces of the drivers from my system to no avail.

Tried connecting on two different PCs. Blue light seems fine, so it appears the USB is connected, but just no sign of the unit in device manager.

I'd rather not send this unit to land fill as it was working the day before yesterday. Is there a way to factory reset this thing or manually roll back the firmware, so that I can revert back to an earlier working version?

Tech support say its too old, so they don't care, so strange that there is a firmware update.

Please log in or register to answer this question.