Questions & Answers

FireStudio 2626 & FireStudio Lightpipe with macOS Ventura

0 votes
1,501 views
asked Nov 11, 2022 in Legacy Interfaces by davecollins (190 points)
edited Nov 16, 2022 by davecollins
How can I make my FireStudio 2626 and FireStudio Lightpipe interfaces work with macOS Ventura?

1 Answer

0 votes
answered May 2, 2023 by AlexTinsley (924,900 points)
 
Best answer

(Admin note, changed this question and answer so it is correctly memorialized for the internet to see)

Hi All,

Just wanted to share some info on my old firewire interfaces that might help some people. I’ve had a FireStudio 2626 and FireStudio Lightpipe running on my Mac for years now. Everything worked fine until macOS Monterey 12.2. After installing 12.3 the interfaces would no longer work. The Mac saw the interfaces in System Profiler, but they did not appear in Audio MIDI Setup or System Preferences. I upgraded to Ventura 13.0.0 a few weeks ago and nothing changed. Then macOS 13.0.1 was released so I decided to try a full wipe and re-install... It worked! Both units are back online and fully functional!

A few notes:

  • I installed the latest firewire driver (v3.6.4.87069).
  • I have to plug the Lightpipe into the Mac, then daisy-chain the 2626 to the Lightpipe. 
  • I have to start the Lightpipe and let it sync, then turn on the 2626.
  • Sometimes they don’t want to sync. There are two fixes:
    • Turn them off and try again. This is usually what works.
    • Check the clock source in Audio MIDI Setup (since Universal Control doesn't work) and made sure it's set to "Internal" on the Lightpipe - For me, it's the one on the bottom of the list.
  • The MSR works great – Full functionality.
  • All 58 I/O are seen in Audio MIDI Setup and Pro Tools.
  • “PreSonus FireStudio” is seen in System Preferences and can be used for system input/output and System Sounds.
  • Pro Tools runs reliably, even with the buffer all the way down to 32 samples.
  • I have not been able to use Universal Control since macOS 10.13 or 10.14, so I use an older Mac with an OSX Mountain Lion (10.8) partition and UC 1.2 (the last version to support both devices) to zero the levels or make changes. When I plug the units back into the newer Mac, the levels are right where I left them.
  • I discovered that I can use the 2626 as a monitor controller in standalone mode using the same method.
  • I can create monitor mixes in Pro Tools instead of using UC.

System Specs:

  • Mid 2012 13” MacBook Pro, Core i7 2.9GHz, 16GB RAM, 500GB SSD, 750GB HDD
  • macOS Ventura 13.0.1 (via OCLP)
  • Avid Pro Tools Studio 2022.10.0
  • PreSonus FireStudio 2626 w/ MSR Remote
  • PreSonus FireStudio Lightpipe
  • PreSonus FaderPort Classic
  • CM Labs Motormix

I have also read that some people are having success with other firewire interfaces on newer Macs using a Thunderbolt 3 to Thunderbolt 2 adapter, then into a Thunderbolt 2 to Firewire adapter. So despite the doom and gloom of macOS Ventura and Apple Driver Kit not supporting firewire, it seems there’s still some life left in these trusty old interfaces afterall!

Hope this helps someone.

   

UPDATE, 2022-11-16:

I was testing different driver versions and I ended up losing these units again. I remembered reading somewhere that sometimes Monterey & Ventura do not prompt you to re-authorize an app/driver when you re-install it. The solution is to fully uninstall the driver, and you might still need to reset the prompts (deep in Terminal). So I tried the PreSonus firewire driver uninstaller (v3.6.4.87069) but it currently does not work on Ventura - It fails to rewrite the kext cache properly so I removed the following line from the Script:

do shell script "kextcache -update-volume /" with administrator privileges

I re-ran the uninstaller Script and it successfully completed. After a reboot I re-installed the driver - This time macOS prompted me to authorize the driver, then macOS rebuilt the cache on its own. After another reboot the FireStudios were back! They've been working flawlessly for a few days now. Fingers crossed it stays that way!

...