Questions & Answers

UC Surface not connecting to Universal Control

0 votes
2,498 views
asked Mar 5, 2023 in StudioLive Series III by david560 (150 points)
I've been trying off and on for a week to connect UC Surface on my iPad to Universal Control on my Mac mini. Qmix connects just fine, but my StudioLive 24R never appears on the Surface start screen, even when I press scan. I've made sure that access is turned on in the Local Network part of Privacy & Security. I've also tried different computers, different iPads, and different wifi routers. Nothing.

2 Answers

0 votes
answered Mar 8, 2023 by mackjohnson1 (77,160 points)
selected Apr 7, 2023 by mackjohnson1
 
Best answer
Check the the IP address your mixer isn't getting an IP address from the router. Make sure you're in a LAN port and check that your IP mode is set to dynamic.
0 votes
answered Apr 11, 2023 by wzgnubfg (200 points)
Check the version of UC control in your devices. I had a newer version in my laptop than in the mixer and it wouldn't connect. I was able to google and find older versions of UC surface, loaded it, problem solved.
...