Questions & Answers

Auto-Save in background!

+318 votes
1,791 views
asked Oct 11, 2016 in Studio One Feature Requests by eckefett (240 points)
Dear Presonus,

it's a pretty minor thing maybe, but the auto-save should happen in the background! While it's auto-saving I can do for some seconds nothing. But when I count all the seconds together I come a long at least a hour per week which is wasted, due to that it's a simple thing what most of the other DAWs can handle as background activity!

Thanks for your attention!

18 Answers

+19 votes
answered Oct 12, 2016 by AlexTinsley (902,800 points)
selected Dec 11, 2016 by ghasenbeck
 
Best answer

Thank you for the feature request. 

If anyone else agrees or disagrees, then please vote it up, or down. 

To vote:

In agreement click on the little blue triangle pointing up.

In disagreement click on the little blue triangle pointing down.

The developers pay close attention to those that are voted on the most. 

You are allowed one vote. 

Just viewing and agreeing but not clicking on the vote does not help the issue. 

Please click on one or the other. 

+26 votes
answered Oct 12, 2016 by mauroiuliano (3,270 points)
I would not call it a minor one. It is very bothering in terms of workflow
+24 votes
answered Oct 26, 2016 by thefliptones (770 points)
This is the bane of my Studio One experience. It's a ******* horrible thing to have to deal with. PLEASE FIX IT!!
+19 votes
answered Oct 27, 2016 by rickycooke (4,810 points)
I absolutely agree. It's especially terrible when you're tracking a singer or performer when they're in their zone and have to tell them to "hold on" because Studio One is saving. It can really stifle creativity and ruin a moment.
+18 votes
answered Feb 25, 2017 by stuartmaxwell (3,060 points)
Agreed, this one really is an unwelcome bug. Please fix it presonus !
+12 votes
answered Mar 25, 2017 by jamesmaxwell (950 points)
Obviously, this should be extended to saving in general, not just auto-save. I'm a dinosaur who's been creating music on the computer since the '90s, so I save obsessively—"command-S" before I even realize I've done it! Having to wait for the save is disruptive, to say the least... (And just bizarre really. I don't know of any other audio creation program that does this.) Am I just missing something, perhaps?
+15 votes
answered Aug 14, 2017 by vasilykorytov (9,970 points)
it's really a shame that S1 behaves like this. it auto-saves in foreground even while playing (and thus does not respond to keyboard if you're stopping the playback or tweaking some parameters). this seems very inconvenient.
+10 votes
answered Sep 10, 2017 by anatolyshiryayev (680 points)
I find S1's auto-save implementation really frustrating. I just can't decide what to do with it: turn off and program myself to press cmd+s from time to time, or leave it on and stop working while popup blocks access to S1 for a few seconds. In fact, stealthy auto-save is number one feature which i'm missing from my previous DAW.
+10 votes
answered Nov 27, 2017 by diapasonprodues (2,470 points)
This is specially bad when I have Melodyne loaded on events on my session. Without melodyne the auto-save is pretty much instantaneous and I barely notice. But with melodyne I'm loosing a few seconds every few minutes waiting for a save or trying to click but nothing happens.
+7 votes
answered Dec 30, 2017 by zarjos (370 points)
Autosave  option to only save when transport is in the stop position would be nice.
+10 votes
answered Jun 9, 2019 by aerotake (430 points)
Still the most glaring flaw in this (otherwise amazing) DAW in 2019
+8 votes
answered Nov 8, 2019 by robromano1 (620 points)
This THE SINGLE MOST ANNOYING / FRUSTRATING THING i’ve seen on a DAW so far, please fix it !!
+6 votes
answered Jan 10 by orphario (410 points)
edited Jan 10 by orphario
Why is presonus neglecting such a critical flaw even in the year 2020?
You may not be bothered if the session is just pasting audio, but it is a serious problem for those who need to program a lot of instruments, such as orchestras.
For example, when multiple instances are started using Vienna Ensemble Pro, it takes about 30 seconds to save or auto-save.
In my case, the auto-save interval is set to 8 minutes, but if I work for 4 hours, a simple calculation will result in a total of 15 minutes of useless time.
Should I be reading comics during that time?
+1 vote
answered May 26 by stuartmaxwell (3,060 points)
I also find this very annoying, weirdly though my V1 single channel faderport still operates transport functions when saving, I had a faderport 16 in the past and it didn't , I'd assume the new single channel faderport doesn't operate when saving either ...
+2 votes
answered Jul 14 by saradis (560 points)
This is still a thing, and saving is even slower in version 5... And on large projects it just kills everything for like half a minute... TERRIBLE
0 votes
answered Jul 20 by DrSnake (160 points)
My latest project is now saving for ~5-10 seconds, is there any progress on this?
0 votes
answered Oct 10 by leedickholtz (970 points)

Great suggestion. Auto-save can be so useful. Has saved me from losing a lot of work, on numerous occasions, though I'd initially disabled it. Was really getting in the way... every 5 minutes.

Some excellent comments and suggestions here. Perhaps they could be summed up as: 'Improve autosave by allowing it to be more patient'

  • Watching for user-specified interaction types...
  • Perhaps a popup on an alternate monitor... auto-save in x amount of time, Delay? Now?
0 votes
answered Oct 22 by benosin2002 (240 points)
Mine has been saving and it takes almost 5 minutes and I can't do any work. Logic or cubase doesn't do this. At least make it save while we work and not stop us from working. It's not cool at all. It's unlike all your nice features. This is the achilles heel
...